Tout ce qui concerne la notion de paquet et comment installer.

Installation d'applications ?

#1Messageil y a 1 an

Bonjour,

Lorsque j'utilise l’application "Ajouter/supprimer des logiciels" il y a souvent des dépendances à choisir.
Pour l'instant, ne sachant pas quoi faire je sélectionne tout, si je ne sélectionne aucune dépendance c'est bon quand même ?

Cordialement.
Dernière modification par cailleil y a 7 mois, modifié au total 1 fois.

Installation d'applications ?

#2Messageil y a 1 an

Il faut être plus précise :wink:

Installation d'applications ?

#3Messageil y a 1 an

Ici tu parles des dépendances optionnelles proposées par pamac ?

puisque qu'elles sont optionnelles, il n'y a pas de raison de les installer sauf un besoin spécifique ... les installer toutes automatiquement :
- surcharge de ton espace disque
- beaucoup plus de paquets lors des mises à jour
- très souvent l'application devient plus lourde en mémoire et plus lente puisqu'elle va charger ces "options"

Il faut voir ces dépendances optionnelles comme les extensions de ton navigateur web :wink:

Installation d'applications ?

#4Messageil y a 1 an

Oui, c'est bien ça.
Il est probablement possible de les désinstaller facilement.
Je commence déjà a trouver cette distribution plus à mon goût que Ubuntu.
Surtout qu'elle n'a rien à voir non plus avec Xubutu qui utilise pourtant aussi xfce ?

Installation d'applications ?

#5Messageil y a 1 an

Bonjour,

J'ai constaté sur AUR que pour l'installation des applications il est indiqué "Construire" au lieu de "Installer"
Ça indique que l'application sera compilée à l'installation, ou ça n'a rien à voir ?

Cordialement.

Installation d'applications ?

#6Messageil y a 1 an

oui c'est bien cela, AUR n'héberge aucun paquet !
uniquement des recettes que nous téléchargeons depuis aur
En local sur notre machine, notre manjaro va exécuter cette recette :
- télécharger les sources chez le développeur
- compiler si c'est un language compilé (C,rust,go,...)
- générer un paquet manjaro
- installer ce paquet généralement avec pacman ou pamac

Ces recettes sont faites par monsieur (ou madame) tout le monde, changent parfois de propriétaires et parfois peuvent êtres cassées

En fonction du langage et du code, la phase de compilation peut-être très longue

Installation d'applications ?

#7Messageil y a 1 an

Sous Ubuntu il y a les PPA, comment sont géré ici les mises à jour et changement de version de logiciels ?
Y aurait-il dans certains cas des versions plus récentes des mêmes logiciels dans AUR que dans Pamac-Manager
En fait sous Ubuntu j'utilise le logiciel Darktable pour le traitement de fichiers photos bruts (RAW).
darktable 3.0.1 Snap et développement (aujourd'hui), darktable_3.1.0_git1031.8e4d22171_amd64
Si je veux installer cette même version de Darktable sous Manjaro, il est possible de trouver les dépôts unstable ?
Darktable est le seul logiciel que je désire installer en version unstable, il fonctionne plutôt bien sous Ubuntu.

Installation d'applications ?

#8Messageil y a 1 an

Les systèmes basés sur Arch utilisent de PKGBUILD qui sont les recettes pour construire un paquet.
Un PPA sous Ubuntu est un dépôt privé qui contient des paquets près à l'installation donc avec un niveau de sécurité aléatoire.
Ici, seuls les dépôts officiels contiennent des paquets construits avec leur N° de version en désignation.
Aur ne contient que des PKGBUILD et quelques fichiers .install consultables. Les PKGBUILD ont des lignes:

pkgname=NAME
pkgver=VERSION
pkgrel=1
Si tu as un Aur-helper ou si tu as autorisé Pamac (et non pacman) a vérifier les mises à jour depuis Aur, tu sera informée qu'une version plus récente est disponnible.
Il arrive qu'un utilisateur propose sur Aur une nouvelle version d'un paquet alors que nos développeurs n'ont pas eu encore le temps d'actualiser.
C'est pourquoi tu peux avoir ce message "paquet-bidule est plus récent que ....."

Installation d'applications ?

#9Messageil y a 1 an

lemust83 a écrit : il y a 1 an Si tu as un Aur-helper ou si tu as autorisé Pamac (et non pacman) a vérifier les mises à jour depuis Aur, tu sera informée qu'une version plus récente est disponnible.
Oui, c'est configuré comme ça, par contre je n'ai pas coché développement.

Image

Installation d'applications ?

#10Messageil y a 1 an

caille a écrit : il y a 1 an Si je veux installer cette même version de Darktable sous Manjaro
une version **-git dans aur est une "version du jour"

elle va prendre les sources à l'instant ou tu l'installes (il n'y a donc pas d'assurance qu'elle fonctionne: la dernière modification ne peut avoir que 3 minutes!) elles sont donc des applications normalement destinées aux développeurs :wink:
Dans aur, la version donnée par ***-git est toujours fausse, il ne faut pas en tenir compte puisqu'elle peut changer chaque jour, chaque heure (le mainteneur de la recette ne prends pas le temps de la changer à chaque fois)

Une application -git n'est pas mise à jour automatiquement (heureusement sinon c'est plusieurs fois par jour) donc une solution c'est de la réinstaller tout simplement de temps en temps (attention au temps de compilation...) ou de cocher ta case "vérifier paquets de développement" dans ton pamac(mais si un seul changement dans les sources, tu repars pour une compilation/install ... si tu as du temps à perdre...)

---
Si tu regardes la version 3.1 elle a 1000 modifications de moins que la version git :? rien depuis Décembre 2019 donc certainement pas une version fraîche
Mais je ne connais pas ce soft, donc je ne vais pas te dire quelle version installer.

Installation d'applications ?

#11Messageil y a 1 an

Bonsoir,

Merci pour ta réponse !

La version de Darktable que j'indique existe sur ce lien pour plusieurs distributions, (pas Manjaro).
https://software.opensuse.org/download. ... =darktable
Sur le lien ci-dessus il y a plusieurs compilations par jour, je l'utilise depuis plusieurs mois et elle est assez stable.

Cordialement.

Installation d'applications ?

#12Messageil y a 1 an

oui donc rien de particulier ; c'est justement la version sur la branche master comme celle de aur

Installation d'applications ?

#13Messageil y a 1 an

:bjr:
papajoke a écrit : il y a 1 an Si tu regardes la version 3.1 elle a 1000 modifications de moins que la version git :? rien depuis Décembre 2019 donc certainement pas une version fraîche
Mais je ne connais pas ce soft, donc je ne vais pas te dire quelle version installer.
Bonjour,

Non, c'est la 3.1.0+0 qui a 1282 modifications de moins que la version 3.1.0+1282 (darktable_3.1.0_git1282.615016be4_amd64)
La 3.1.0+0 est sortie le 21 décembre 2019, après la mise en ligne de la version 3.0.0 stable.
La 3.1.0+1282 est la dernière version master de darktable, sortie aujourd'hui, mercredi 22 avril 2020.
Voir ci-dessous (il faut cliquer sur xxxx commits pour voir les modifications depuis décembre xxxx = 1282 aujourd'hui).

Image

Si je désire compiler cette version sous Manjaro, (qui fonctionne très bien sous Ubuntu), je fais comment ?
Faut-il installer également des dépendances comme sous Ubuntu ou sont-elles intégrés dans Manjaro ?
sudo apt-get install git gcc g++ cmake intltool xsltproc libgtk-3-dev libxml2-utils libxml2-dev liblensfun-dev librsvg2-dev libsqlite3-dev libcurl4-gnutls-dev libjpeg-dev libtiff5-dev liblcms2-dev libjson-glib-dev libexiv2-dev libpugixml-dev libcolord-dev libcolord-gtk-dev libcups2-dev libgphoto2-dev libsoup2.4-dev libopenexr-dev libwebp-dev libosmgpsmap-1.0-dev libflickcurl-dev libsecret-1-dev libgraphicsmagick1-dev llvm clang liblua5.3-dev
Il faudra bien sur modifier le commande d'installation: sudo apt-get install
papajoke a écrit : il y a 1 an elle va prendre les sources à l'instantou tu l'installes (il n'y a donc pas d'assurance qu'elle fonctionne: la dernière modification ne peut avoir que 3 minutes!) elles sont donc des applications normalement destinées aux développeurs :wink:
Dans aur, la version donnée par ***-git est toujours fausse, il ne faut pas en tenir compte puisqu'elle peut changer chaque jour, chaque heure (le mainteneur de la recette ne prends pas le temps de la changer à chaque fois)
Elle n'est pas disponible sur AUR, voir ci-dessous, il faut donc bien la compiler ?

Image

Image

La dernière version stable 3.0.2 est sortie le 17 avril 2020 et n'est pas disponible non plus ?

Cordialement.

Installation d'applications ?

#14Messageil y a 1 an

Bonjour.
La version Aur pointe vers le dépôt git de Darktable.
Comme le dit Papajoke, des modif de dernières minutes sont envisageables .
Pour le compiler, le mieux étant de faire:

git clone 'https://aur.archlinux.org/darktable-git.git'
cd Darktable-git/
makepkg -si
A noter que tu auras probablement pas mal de dépendances a installer, beaucoup venant de Aur...

Edit : Fait avec les commandes ci-dessus. Version 3.1.0


Image

Installation d'applications ?

#15Messageil y a 1 an

Bonjour,

Cette commande fonctionne bien:

git clone https://github.com/darktable-org/darktable.git .darktable_master/
Celles-ci aussi:

git submodule init
git submodule update
Donc mes sources sont bien téléchargées !

Les dépendances sont ici: https://redmine.darktable.org/projects/ ... rktable_26

Mais ce doit-être des dépendances différentes pour Manjaro ?

[caille@caille-n76vb ~]$ sudo pacman -S git gcc g++ cmake intltool xsltproc libgtk-3-dev libxml2-utils libxml2-dev liblensfun-dev librsvg2-dev libsqlite3-dev libcurl4-gnutls-dev libjpeg-dev libtiff5-dev liblcms2-dev libjson-glib-dev libexiv2-dev libpugixml-dev libcolord-dev libcolord-gtk-dev libcups2-dev libgphoto2-dev libsoup2.4-dev libopenexr-dev libwebp-dev libosmgpsmap-1.0-dev libflickcurl-dev libsecret-1-dev libgraphicsmagick1-dev llvm clang liblua5.3-dev
avertissement : git-2.26.2-1 est à jour -- réinstallation
avertissement : gcc-9.3.0-1 est à jour -- réinstallation
erreur : impossible de trouver la cible : g++
erreur : impossible de trouver la cible : xsltproc
erreur : impossible de trouver la cible : libgtk-3-dev
erreur : impossible de trouver la cible : libxml2-utils
erreur : impossible de trouver la cible : libxml2-dev
erreur : impossible de trouver la cible : liblensfun-dev
erreur : impossible de trouver la cible : librsvg2-dev
erreur : impossible de trouver la cible : libsqlite3-dev
erreur : impossible de trouver la cible : libcurl4-gnutls-dev
erreur : impossible de trouver la cible : libjpeg-dev
erreur : impossible de trouver la cible : libtiff5-dev
erreur : impossible de trouver la cible : liblcms2-dev
erreur : impossible de trouver la cible : libjson-glib-dev
erreur : impossible de trouver la cible : libexiv2-dev
erreur : impossible de trouver la cible : libpugixml-dev
erreur : impossible de trouver la cible : libcolord-dev
erreur : impossible de trouver la cible : libcolord-gtk-dev
erreur : impossible de trouver la cible : libcups2-dev
erreur : impossible de trouver la cible : libgphoto2-dev
erreur : impossible de trouver la cible : libsoup2.4-dev
erreur : impossible de trouver la cible : libopenexr-dev
erreur : impossible de trouver la cible : libwebp-dev
erreur : impossible de trouver la cible : libosmgpsmap-1.0-dev
erreur : impossible de trouver la cible : libflickcurl-dev
erreur : impossible de trouver la cible : libsecret-1-dev
erreur : impossible de trouver la cible : libgraphicsmagick1-dev
erreur : impossible de trouver la cible : liblua5.3-dev
[caille@caille-n76vb ~]$ sudo pacman -S cmake

[caille@caille-n76vb ~]$ sudo pacman -S cmake
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (4) jsoncpp-1.9.2-1  libuv-1.37.0-1  rhash-1.3.9-1  cmake-3.17.1-2

Taille totale du téléchargement :   8,84 MiB
Taille totale installée :        41,65 MiB

:: Procéder à l’installation ? [O/n] o
:: Récupération des paquets…
 jsoncpp-1.9.2-1-x86_64                           1190,5 KiB  1148 KiB/s 00:01 [############################################] 100%
 libuv-1.37.0-1-x86_64                             219,4 KiB  1371 KiB/s 00:00 [############################################] 100%
 rhash-1.3.9-1-x86_64                              151,7 KiB  1167 KiB/s 00:00 [############################################] 100%
 cmake-3.17.1-2-x86_64                               7,3 MiB  1317 KiB/s 00:06 [############################################] 100%
(4/4) vérification des clés dans le trousseau                                  [############################################] 100%
(4/4) vérification de l’intégrité des paquets                                  [############################################] 100%
(4/4) chargement des fichiers des paquets                                      [############################################] 100%
(4/4) analyse des conflits entre fichiers                                      [############################################] 100%
(4/4) vérification de l’espace disque disponible                               [############################################] 100%
:: Traitement des changements du paquet…
(1/4) installation de jsoncpp                                                  [############################################] 100%
Dépendances optionnelles pour jsoncpp
    jsoncpp-doc: documentation
(2/4) installation de libuv                                                    [############################################] 100%
(3/4) installation de rhash                                                    [############################################] 100%
(4/4) installation de cmake                                                    [############################################] 100%
Dépendances optionnelles pour cmake
    qt5-base: cmake-gui [installé]
:: Exécution des crochets de post-transaction…
(1/4) Arming ConditionNeedsUpdate...
(2/4) Updating icon theme caches...
(3/4) Updating the desktop file MIME type cache...
(4/4) Updating the MIME type database...
[caille@caille-n76vb ~]$ sudo pacman -S gcc
avertissement : gcc-9.3.0-1 est à jour -- réinstallation
résolution des dépendances…
recherche des conflits entre paquets…

Paquets (1) gcc-9.3.0-1

Taille totale installée :    139,32 MiB
Taille de mise à jour nette :    0,00 MiB

:: Procéder à l’installation ? [O/n] o
(1/1) vérification des clés dans le trousseau                                  [############################################] 100%
(1/1) vérification de l’intégrité des paquets                                  [############################################] 100%
(1/1) chargement des fichiers des paquets                                      [############################################] 100%
(1/1) analyse des conflits entre fichiers                                      [############################################] 100%
(1/1) vérification de l’espace disque disponible                               [############################################] 100%
:: Traitement des changements du paquet…
(1/1) réinstallation gcc                                                       [############################################] 100%
:: Exécution des crochets de post-transaction…
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the info directory file...
[caille@caille-n76vb ~]$ /opt/darktable_master/bin/darktable --configdir /home/nicolas/.config/darktable_master/
bash: /opt/darktable_master/bin/darktable: Aucun fichier ou dossier de ce type
[caille@caille-n76vb ~]$ ./build.sh --prefix /opt/darktable_master/ --build-type Release
bash: ./build.sh: Aucun fichier ou dossier de ce type
[caille@caille-n76vb ~]$ cd .darktable_master/
[caille@caille-n76vb .darktable_master]$ ./build.sh --prefix /opt/darktable_master/ --build-type Release
Darktable build script
Pour lancer la compilation j'ai utilisé cette ligne, ça démarre bien mais ça ne ce termine pas.
Il doit me manquer des dépendances, j'ai essayé de les installer mais ça ne fonctionne pas bien.

sudo pacman -S "nom des paquets" Ce ne doit pas être ça ?

./build.sh --prefix /opt/darktable_master/ --build-type Release
J'obtiens deux fichiers (pour infos ci-dessous).

Sous Ubuntu la première compilation prend 2'40 ensuite les mises à jours moins d'une minute.

See also "/home/caille/.darktable_master/build/CMakeFiles/CMakeError.log".
https://www.cjoint.com/c/JDwpBhTx3Pg

See also "/home/caille/.darktable_master/build/CMakeFiles/CMakeOutput.log".
https://www.cjoint.com/c/JDwpCZdxIrg

Installation d'applications ?

#16Messageil y a 1 an

as tu installé base-devel
ajoute le d'abord

sudo pacman -S base-devel 
puis tu relance la compilation

Installation d'applications ?

#17Messageil y a 1 an

:salut:

Je ne comprends rien à ce que tu essayes de faire , on te dit que la version aur git est la dernière (celle au moment ou tu compiles), alors pourquoi tu ne l'installes pas ? si actuellement la branche master est la 3.1 tu auras la 3.1 c'est aussi simple que cela, si tu la ré-installes dans 8 jours tu auras la 3.1 avec les commits(modifications) depuis 8 jours.
Le version aur -git fait justement la même chose que toi mais de façon propre, perso il ne me viendrait pas à l'idée de me compliquer la vie (ou si absolument nécessaire alors on fait une nouvelle recette)

C'est toujours une mauvaise idée de vouloir installer une application à la façon ubuntu ! Et c'est une mauvaise pratique d'installer toutes tes dépendances implicitement (elles ne seront jamais marquées orphelines donc on se retrouve vite fait avec des paquets sans intérêt pour nous qui vont polluer notre distribution et nos mises à jour). Nous sommes en rolling, nous ne ré-installons pas tous les an ! alors on évite au maximum de trainer des casseroles toute la durée de vie de notre disque (5.. 10 ans ?)

Installation d'applications ?

#18Messageil y a 1 an

stephane a écrit : il y a 1 an as tu installé base-devel
ajoute le d'abord

sudo pacman -S base-devel 
puis tu relance la compilation
Bonjour,

Merci pour vos réponses !

Non je n'ai pas installé base-devel, je vais essayer.

Question :

1) autoconf  2) automake  3) binutils  4) bison  5) fakeroot  6) file  7) findutils  8) flex  9) gawk  10) gcc  11) gettext  12) grep  13) groff  14) gzip  15) libtool  16) m4  17) make
   18) pacman  19) patch  20) pkgconf  21) sed  22) sudo  23) texinfo  24) which
   
Entrer une sélection (par défaut, tout est sélectionné): 
J'ai choisis par défaut ! Réponse !

[caille@caille-n76vb .darktable_master]$ ./build.sh --prefix /opt/darktable_master/ --build-type Release
Darktable build script

Building directory:  /home/caille/.darktable_master/build
Installation prefix: /opt/darktable_master/
Build type:          Release
Build generator:     Unix Makefiles
Build tasks:         8


-- Found OpenMP_C: -fopenmp (Required is at least version "4.5") 
-- Found OpenMP_CXX: -fopenmp (Required is at least version "4.5") 
-- Found OpenMP: TRUE (Required is at least version "4.5")  
-- Is the target platform supported: 1
-- Found little endian system. Good.
-- Building SSE2-optimized codepaths: ON
-- Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=varargs
-- Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=varargs - Success
-- Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=varargs
-- Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=varargs - Success
-- Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member
-- Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member - Success
-- Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member
-- Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member - Success
-- Looking for external programs
-- Found perl
-- Missing intltool-merge
-- Found desktop-file-validate
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
-- Could NOT find LLVM (missing: LLVM_DIR)
CMake Warning at CMakeLists.txt:329 (message):
  Could not find LLVM 3.9+


CMake Warning at CMakeLists.txt:330 (message):
  Test-compilation of OpenCL programs can not be done.


-- Test-compilation of OpenCL programs is disabled.
-- Missing jsonschema, problems in noiseprofiles.json might go unnoticed
-- Found xsltproc
-- Found xmllint
-- Found exiftool
CMake Error at CMakeLists.txt:388 (message):
  Some external programs couldn't be found


-- Configuring incomplete, errors occurred!
See also "/home/caille/.darktable_master/build/CMakeFiles/CMakeOutput.log".
See also "/home/caille/.darktable_master/build/CMakeFiles/CMakeError.log".
[caille@caille-n76vb .darktable_master]$ 
papajoke a écrit : il y a 1 an:salut:

si actuellement la branche master est la 3.1 tu auras la 3.1 c'est aussi simple que cela, si tu la ré-installes dans 8 jours tu auras la 3.1 avec les commits(modifications) depuis 8 jours.
Le version aur -git fait justement la même chose que toi mais de façon propre, perso il ne me viendrait pas à l'idée de me compliquer la vie (ou si absolument nécessaire alors on fait une nouvelle recette)
Bonjour papajoke,

Non la version de AUR que j'ai installé n'est pas la dernière version, je viens de le faire aujourd'hui, c'est la version 3.0.1 stable ?
Alors si il y a une solution pour l'installer directement sans faire de compilation je suis preneur, je n'ai pas du faire ce qu'il fallait.
J'ai indiqué avec mes captures écrans ci-dessus, ce qui est disponible et listés dans AUR, il n'y a aucune version 3.1.0 de listée ?
Il y a peut-être quelque chose à paramétrer dans AUR pour y avoir accès ?

Cordialement.

Installation d'applications ?

#19Messageil y a 1 an

je viens de lancer aur -git marqué en version 2.5 (suis pas allé au bout)

Lancement de pkgver()…
==> Version mise à jour : darktable-git release.3.1.0.r1282.g615016be4-1
==> Les sources sont prêtes.
==> Création du paquet darktable-git release.3.1.0.r1282.g615016be4-1 (mer. 22 avril 2020 19:22:09)
et donc comme marqué ici, le dernier commit est 615016be4 qui est bien celui d'aujourd'hui :

Tino Mettler
Tino Mettler authored and TurboGit committed 21 hours ago 
commit 615016be4184134d92beff54efe16114c385073f
'installer directement sans faire de compilation
justement non, avec -git on compile toujours . Après, il y a peut-être moyen de faire une recette "-bin" à partir des paquets deb ou rpm (existe par exemple avec firefox alpha "du jour")

Installation d'applications ?

#20Messageil y a 1 an

papajoke a écrit : il y a 1 an je viens de lancer aur -git marqué en version 2.5 (suis pas allé au bout)

Lancement de pkgver()…
==> Version mise à jour : darktable-git release.3.1.0.r1282.g615016be4-1
==> Les sources sont prêtes.
==> Création du paquet darktable-git release.3.1.0.r1282.g615016be4-1 (mer. 22 avril 2020 19:22:09)
et donc comme marqué ici, le dernier commit est 615016be4 qui est bien celui d'aujourd'hui :

Tino Mettler
Tino Mettler authored and TurboGit committed 21 hours ago 
commit 615016be4184134d92beff54efe16114c385073f
'installer directement sans faire de compilation
justement non, avec -git on compile toujours
Suite...

Je n'ai pas compris ce que tu as tapé en ligne de commande ?
Lancement de pkgver()…
Moi j'utilise l'application paquets de Manjaro, ce ne doit pas être ça ?

C'est quoi ? pkgver()... ?

Je n'ai pas compris ce que tu lance ? je viens de lancer aur -git marqué en version 2.5 (suis pas allé au bout) ?
Répondre