Problèmes et questions sur les applications multimédia.
Répondre

lecteur vidéo puissant

#1Messageil y a 7 mois

Bonjour,
J'utilise principalement VLC et SMPlayer mais pour la 4k je trouve que PowerDVD (Windows) a une excellente qualité d'image (plus de nuances, flagrant avec les noirs), le curseur de la barre de lecture réagit instantanément, il y a parfois des latences avec les autres lecteurs voir même des pixels, ca freeze 2 secondes puis redémarre.
Existe il sur Linux un lecteur vidéo dédié aux films lourds ?
J'ai testé Clementine et Mplayer je n'ai vu aucune différence avec VLC et SMPlayer.
Merci

lecteur vidéo puissant

#2Messageil y a 7 mois

Bonjour,
Je pense qu'il faudrait regarder du côté des pilotes Nvidia, lequel utilises-tu?
De plus, apparemment dans VLC il y a plusieurs solutions pour ces problèmes.
Je te laisse voir si une des solutions du lien ci-dessous fonctionne chez toi :
https://www.remosoftware.com/fr/comment ... ture-video
Et si quelque chose résout ton problème, n'hésite pas à le partager ici :gsourire:

Bon courage

lecteur vidéo puissant

#3Messageil y a 7 mois

Bonjour eric,
Je n'utilise pas de pilote Nvidia, j'ai cru comprendre qu'il valait mieux laisser le pilote Linux, non?
Image
Merci pour le lien VLC, il est suggéré d'activer "le décodage accéléré par GPU", je vais voir ca.
J'aurai du préciser que la lecture en 4k fonctionne mais les problèmes de latence+pixels arrivent uniquement quand je déplace le curseur de lecture...En gros, je lance le film et ne touche plus à rien sauf le son.
D'ailleurs je m'apprête à comparer la vitesse des rendus de Blender sur Manjaro/Windows10 en modifiant le rapport GPU/CPU, je lis tout et son contraire sur les performances de Linux avec Blender (matos+paramétrage) et n'ai pas encore bien compris la manip mais se sera un autre post..

lecteur vidéo puissant

#4Messageil y a 7 mois

bonjour , il y a une erreur pour les drivers Nvidia les 390 sont pour les vieilles cartes Nvidia ,
pour les générations 960 et plus ( donc depuis 2015) , on utilise les drivers récents.

le rendu par le cpu ( 6700K) est bridé par les mitigations cpu & memoire gpu ( drm i915 )

un retour d'info serait bien utile

inxi -Fza
sudo mhwd-kernel -li 

lecteur vidéo puissant

#5Messageil y a 7 mois

Bonsoir Stephane,
Donc pour ma GTX1070 je peux installer un driver autre que video-linux ?
Le site Nvidia propose la version 460.67, pamac 460.56-2, lequel est a privilégier ?

Qu'entends tu par "Le cpu est bridé par les mitigations cpu & memoire gpu" ?

Les infos:

^[[DSystem:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=2e53a8b1-24e0-43bb-b0f3-9a4d6ca50bd7 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Desktop System: MSI product: MS-7971 v: 1.0 serial: <filter> 
           Mobo: MSI model: Z170-A PRO (MS-7971) v: 1.0 serial: <filter> UEFI-[Legacy]: American Megatrends v: 1.D0 
           date: 08/30/2016 
Battery:   Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard K270 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S family: 6 model-id: 5E (94) 
           stepping: 3 microcode: E2 cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 64026 
           Speed: 4013 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 4013 2: 4001 3: 4026 4: 4000 5: 4000 6: 4001 7: 3998 
           8: 4000 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: ASUSTeK driver: nouveau v: kernel bus-ID: 01:00.0 
           chip-ID: 10de:1b81 class-ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") s-diag: 1245mm (49") 
           Monitor-1: DVI-D-1 res: 1920x1080 hz: 60 dpi: 102 size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
           Monitor-2: HDMI-1 res: 2560x1440 hz: 60 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           OpenGL: renderer: NV134 v: 4.3 Mesa 20.3.4 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403 
           Device-2: NVIDIA GP104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:10f0 class-ID: 0403 
           Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.23 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Belkin F8T065BF Mini Bluetooth 4.0 Adapter type: USB driver: btusb v: 0.8 bus-ID: 1-12.3:5 
           chip-ID: 050d:065a class-ID: fe01 serial: <filter> 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 3.22 TiB used: 44.24 GiB (1.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G size: 447.13 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: B1D1 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDA240G size: 223.57 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 80RL scheme: MBR 
           ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD5000AAVS-00G9B0 size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 4C05 scheme: MBR 
           ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST3320418AS size: 298.09 GiB block-size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC6B scheme: MBR 
           ID-5: /dev/sde maj-min: 8:64 vendor: Seagate model: ST1000DM003-1SB102 size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
           ID-6: /dev/sdf maj-min: 8:80 vendor: Seagate model: ST1000DM003-1SB10C size: 931.51 GiB block-size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: MBR 
Partition: ID-1: / raw-size: 223.57 GiB size: 219.06 GiB (97.98%) used: 44.24 GiB (20.2%) fs: ext4 dev: /dev/sdb1 
           maj-min: 8:17 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 37.5 C mobo: 29.8 C gpu: nouveau temp: 46.0 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 825 
Info:      Processes: 250 Uptime: 10h 29m wakeups: 52 Memory: 31.33 GiB used: 2.13 GiB (6.8%) Init: systemd v: 247 
           tool: systemctl Compilers: gcc: 10.2.0 Packages: pacman: 1401 lib: 429 flatpak: 0 Shell: Bash v: 5.1.0 
           running-in: yakuake inxi: 3.3.03 

Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
   * linux54
   * linux59

lecteur vidéo puissant

#6Messageil y a 6 mois

bonjour
1) ton UEFI n'est pas a jour ( 2016 ..)

2) tu as juste le noyau 5.4 et 5.9 , tu devrais avoir
5.4 et 5.10 , et le 5.11 en cours

sudo pacman -Syyu
sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux511 
redémarrer

sudo mhwd-kernel -r linux59
pour les drivers nvidia , et vu le nombre d'ecrans , ton fichier Xorg devra être revu ensuite sous KDE ( ecran 1 , 2 , etc )

***obligatoire ***
tu lance une TTY (Ctrl+Alt +F2 a F7 et login ) ou Terminal

sudo mhwd -a pci nonfree 0300
sudo mkinitcpio -P
3) pour info , les options UEFI pour démarrer sur manjaro c'est
- pas secure boot
- pas de fast boot
- pas de CSM
- pas de legacy
- tous les disques en AHCI
tu as intérêt a sauvegarder un profil pour linux et un autre pour windows sous ton EFI

avoir UEFI[Legacy] c'est source de probleme
( en gros demande démarrage EFI , bascule en MBR )
==> impact qui concerne tous les disques , donc c'est pour info
normalement par ce biais UEFI --> disque linux GPT +/boot/efi

3) techniquement le GPT est de loin mieux que le MBR
gérer par contre les 2 sous linux n'est pas conseillé
( attention GPT ou MBR c'est un formatage disque garanti donc a revoir su la manière de faire )

lecteur vidéo puissant

#7Messageil y a 6 mois

Merci docteur, le bilan n'est donc pas génial..
1) J'ai effectué les commandes suivantes:

sudo pacman -Syyu
sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux511

sudo mhwd-kernel -r linux59

sudo mhwd -a pci nonfree 0300
sudo mkinitcpio -P
J'ai l'impression que mon manjaro tourne plus vite.
Je croyais qu'il fallait 2 noyaux, 1 noyau utilisé et un autre de récup, hors là j'en ai 3 :
Image

2) La maj de l'uefi est elle obligatoire même sans dualboot ? j'ai lu sur Lecrabe et Malekal que ca pouvait être dangereux ?!

3) Je reviens au sujet du post, lecteur 4k puis performances gpu/cpu...
Je suis sur windows pour la suite Adobe et n'ai besoin de rien d'autre, donc linux m'est utile uniquement si Blender tourne réellement plus vite en fonction du matos et des réglages dans blender.
Si les écarts des performances sont minimes, linux n'aura plus d’intérêt.
J'utiliserai linux sur mon portable pour internet/textes/films, je pense à fedora 34.
Désolé pour ce post un peut fourre-tout :lol:

lecteur vidéo puissant

#8Messageil y a 6 mois

le point 2) permet de corriger les anomalies UEFI et parfois de mettre a jour le microcode

lecteur vidéo puissant

#9Messageil y a 6 mois

Salut,
Oscar a écrit : il y a 7 mois Merci pour le lien VLC, il est suggéré d'activer "le décodage accéléré par GPU", je vais voir ca.
J'aurai du préciser que la lecture en 4k fonctionne mais les problèmes de latence+pixels arrivent uniquement quand je déplace le curseur de lecture...En gros, je lance le film et ne touche plus à rien sauf le son.
Les lecteurs vidéo sous Linux utilisent les fonctions OpenGL/3D de la carte graphique et le pilote libre Nvidia est très mauvais dans ce domaine, tu n'as pas d'autre choix que d'utiliser le pilote propriétaire.

Que ce soit pour VLC ou Mpv (SMPlayer n'est qu'une interface graphique pour Mpv), les réglages par défaut sont fait pour convenir à toutes les machines, même celles peu puissantes. La qualité du rendu d'image peut s'améliorer, mais il faut savoir quels paramètres choisir, et c'est encore moins évident pour de l'image non 4K (1080p, 720p) sur un écran 4K.
Répondre