Problèmes et questions concernant l'édition KDE.

Impossible de lancer Manjaro ?

#21Messageil y a 3 semaines

désolé il manquait une étape intermédiaire
( cela se produit pour des personnes qui passe en GPT , ou qui veulent ajouter /boot/efi )

1) il faut une partition /boot/efi , et l'ajouter dans /etc/fstab avecUUID
cela ne suffit pas , la liaison n'est pas faite réellement , on doit aussi
et refaire un chroot pour la partition /boot/efi et ,
2) créer le répertoire /boot/efi dans / ( il n'existe pas ) ,pour réaliser association avec la partition
3) effectuer ensuite le grub-install pour UEFI

Impossible de lancer Manjaro ?

#22Messageil y a 3 semaines

Bonsoir,

Ce n'est pas grave, vu que ma nouvelle installation fonctionne ce soir.
Par contre je n'ai toujours pas compris ce qui c'était passé pour que le démarrage ne fonctionne pas mardi matin ?
Le boot ce faisait bien, c'est à l'écran de connexion qu'il ce bloquait avec uniquement le pointeur qui bougeait.
Après avoir ajouté un nouveau compte l'écran avait une définition d'affichage anormale, mais la session s'ouvrait.
Plus aucune erreur... :wink:

[manjaro@manjaro ~]$ inxi -Mxa
Machine:
  Type: Laptop System: ASUSTeK product: N76VB v: 1.0 
  serial: <superuser required> 
  Mobo: ASUSTeK model: N76VB v: 1.0 serial: <superuser required> 
  UEFI: American Megatrends v: N76VB.205 date: 05/24/2013 
[manjaro@manjaro ~]$ sudo efibootmgr -v
BootCurrent: 003B
Timeout: 0 seconds
BootOrder: 0001,0003,0002,0000,003A,003B
Boot0000* Windows Boot Manager  HD(2,GPT,a695adab-994b-448c-9a62-c1d4a17b9173,0x109000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0001* Manjaro       HD(2,GPT,a695adab-994b-448c-9a62-c1d4a17b9173,0x109000,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0002* ubuntu        HD(2,GPT,a695adab-994b-448c-9a62-c1d4a17b9173,0x109000,0x32000)/File(\EFI\ubuntu\shimx64.efi)
Boot0003* debian        HD(2,GPT,a695adab-994b-448c-9a62-c1d4a17b9173,0x109000,0x32000)/File(\EFI\debian\shimx64.efi)
Boot003A* ubuntu        HD(2,GPT,a695adab-994b-448c-9a62-c1d4a17b9173,0x109000,0x32000)/File(EFI\Ubuntu\grubx64.efi)
Boot003B* UEFI: USB Flash DISK 1100     PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)/HD(1,MBR,0x0,0x54af78,0x2000)AMBO
[manjaro@manjaro ~]$ test -d /sys/firmware/efi && echo efi || echo bios
efi
[manjaro@manjaro ~]$ sudo lsblk -fs
NAME FSTYPE FSVER LABEL UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0
     squash 4.0                                                    0   100% /run/miso/
loop1
     squash 4.0                                                    0   100% /run/miso/
loop2
     squash 4.0                                                    0   100% /run/miso/
loop3
     squash 4.0                                                    0   100% /run/miso/
sda1 ntfs         Récupération
│                       2A1A45ED1A45B71B                                    
└─sda
                                                                            
sda2 vfat   FAT32       5C46-7558                                           
└─sda
                                                                            
sda3                                                                        
└─sda
                                                                            
sda4 ntfs         Windows_10
│                       1E2A742A2A73FCD9                                    
└─sda
                                                                            
sda5 ext4   1.0   Manjaro_KDE
│                       acbf1fd6-d87d-4603-9b5d-fed2491b55f8                
└─sda
                                                                            
sda6 ext4   1.0   Ubuntu_20.04.1
│                       6e4a5a06-446f-4577-a099-2e15b1298c4a                
└─sda
                                                                            
sda7 ext4   1.0   debian_SID
│                       3d3fd50b-0899-435a-906c-383385a266a9                
└─sda
                                                                            
sda8 ext4   1.0   Debian_Buster
│                       7b307716-be2d-48ef-af16-2d149f54b14d                
└─sda
                                                                            
sda9 ext4   1.0   manjaro-system
│                       2693f90c-2af7-4de4-b56f-7c8e1a38ce5f                
└─sda
                                                                            
sda10
│    ext4   1.0   home-manjaro
│                       711cd1a0-b115-4123-8eda-efc255501a8d                
└─sda
                                                                            
sdb1                                                                        
└─sdb
                                                                            
sdb2 ntfs         HDD   3E64D2DA64D2944D                                    
└─sdb
                                                                            
sdb3 ext4   1.0   AUR   a34033d8-d11e-4326-a9b5-453fbae4006c                
└─sdb
                                                                            
sdc1 iso966 Jolie MANJARO_KDE_2101
│                       2021-04-10-10-33-18-00                              
└─sdc
     iso966 Jolie MANJARO_KDE_2101
                        2021-04-10-10-33-18-00                     0   100% /run/miso/
sdc2 vfat   FAT12 MISO_EFI
│                       A21D-966B                                           
└─sdc
     iso966 Jolie MANJARO_KDE_2101
                        2021-04-10-10-33-18-00                     0   100% /run/miso/
sr0                                                                         
[manjaro@manjaro ~]$ sudo manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdc1.  Check your device.map.
==> Detected systems:
 --> 0) ManjaroLinux
 --> 1) Ubuntu
 --> 2) Debian
 --> 3) Debian1
 --> 4) ManjaroLinux1
==> Select system to mount [0-4] : 
4
==> Mounting (ManjaroLinux1) [/dev/sda9]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
 --> mount: [/mnt/home]
[manjaro /]# nano /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this>
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=5C46-7558                            /boot/efi      vfat    umask=0077>
UUID=2693f90c-2af7-4de4-b56f-7c8e1a38ce5f /              ext4    defaults,n>
UUID=711cd1a0-b115-4123-8eda-efc255501a8d /home          ext4    defaults,n>
tmpfs                                     /tmp           tmpfs   defaults,n>


Passe une bonne soirée. :bien

Impossible de lancer Manjaro ?

#23Messageil y a 3 semaines

Bonjour,

Vu que l'installation que j'ai fait hier sur ma nouvelle Manjaro n'a rien supprimée, je viens de faire la même chose sur celle qui n'a pas démarrée mardi matin. J'ai donc lancé une nouvelle installation en ne sélectionnant qu'un seul point de montage, cette pseudo installation a pris moins de deux minutes. Au démarrage suivant j'ai donc lancé cette distribution, c'est le même résultat que mardi à la différence qu'avant la fenêtre de connexion (mot de passe) j'ai reçu le message suivant:
Configuration file "/var/lib/sddm/.config/sddm-greeterrc" not writable.
Please contact your system administrator....................................Ok
C'est peut-être lié à mon problème de mardi matin ?
Je n'ai rien perdu lors de l'installation, mais je ne suis pas plus avancé, blocage de l'écran au mot de passe.
J'ai essayé d'ouvrir sddm-greeterrc en usb-live sudo manjaro-chroot -a il n'y a rien dedans ?
Image
y a-t-il un "your system administrator" ici.:rigole:
Si cette information peut faire avancer le schmilblick. :oops:
Je viens de trouver ça : https://unix.stackexchange.com/question ... -is-displa

Cordialement.

Impossible de lancer Manjaro ?

#24Messageil y a 3 semaines

Je viens de faire cette commande en tty sous Manjaro avant d'entrer le mot de passe.

sudo touch /var/lib/sddm/.config/sddm-greeterrc
Je n'aurais probablement pas été obligé de réinstaller, mais dans ce cas je n'aurais jamais reçu ce message d'erreur. :oops:
Elle c'est bien ouverte avec le mot de passe, par contre même si elle s'ouvre à chaque fois, je reçois ce message d'erreur ?
J'ai donc fait une autre commande pour donner les droits à "sddm" ?

sudo chown sddm:sddm /var/lib/sddm/.config -R
Je n'ai plus d'erreur au démarrage. :bien
Répondre