Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#1Messageil y a 1 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Bonjour la communauté,
une autre mise à jour de la branche stable pour vous.
Veuillez lire notre avis de sécurité concernant les clés de signature pacman !
  • La plupart de nos noyaux ont été mis à jour
  • Systemd est maintenant à 248.3
  • Les applications Gnome ont été mises à jour vers 40.2
  • Cutefish DE a été mis à jour vers la v0.2
  • Pipewire est à 0.3.29
  • Deepin a reçu de nouvelles mises à jour
  • Autres mises à jour régulières en amont, notamment python et haskell
N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.

Attention: les noyaux 4.19 et 4.9 semblent incompatibles avec le dernier systemd

:oops: Conflit de fichier libcanberra-gstreamer ?
Il est préférable d'utiliser sudo pamac update pour cette mise à jour, sinon avec pacman, désinstaller ce paquet avant mise à jour

-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pamac update
ou encore

sudo pacman -Syu
------------------------------------------------------------------------------------


Noyaux pris en charge :
  • linux44 4.4.271
  • linux49 4.9.271
  • linux414 4.14.235
  • linux419 4.19.193
  • linux54 5.4.124
  • linux510 5.10.42
  • linux511 5.11.22 [EOL] En fin de vie
  • linux512 5.12.9
  • linux513 5.13-rc5 (expérimental)
  • linux510-rt 5.10.35_rt39
  • linux511-rt 5.11.4_rt11
Les changements en détail :
  • community x86_64: 1760 nouveaux et 1752 paquets retirés
  • core x86_64: 40 nouveaux et 40 paquets retirés
  • extra x86_64: 433 nouveaux et 590 paquets retirés
  • kde-unstable x86_64: 384 nouveaux et 383 paquets retirés
  • multilib x86_64: 37 nouveaux et 44 paquets retirés
42 paquets supprimés:

disman-beta hardlink kdisplay-beta kwinft-beta lib32-libcanberra-gstreamer lib32-libcanberra-pulse libcanberra-gstreamer libcanberra-pulse linux54-rt linux54-rt-acpi_call linux54-rt-bbswitch linux54-rt-broadcom-wl linux54-rt-headers linux54-rt-ndiswrapper linux54-rt-nvidia linux54-rt-nvidia-390xx linux54-rt-nvidiabl linux54-rt-r8168 linux54-rt-rtl8723bu linux54-rt-tp_smapi linux54-rt-vhba-module linux54-rt-virtualbox-host-modules linux54-rt-zfs linux59-rt linux59-rt-acpi_call linux59-rt-bbswitch linux59-rt-broadcom-wl linux59-rt-headers linux59-rt-nvidia linux59-rt-nvidia-390xx linux59-rt-r8168 linux59-rt-rtl8723bu linux59-rt-tp_smapi linux59-rt-vhba-module linux59-rt-virtualbox-guest-modules linux59-rt-virtualbox-host-modules mntray pacrep python-couchdb qca sticky wrapland-beta
45 nouveaux paquets:

abseil-cpp:  High performance, open source, general RPC framework that puts mobile and HTTP/2 first.
anewer:  anewer appends lines from stdin to a file if they don t already exist in the file
avogadro-crystals:  Crystallographic files of common materials, elements, oxides, for visualization in Avogadro
avogadro-molecules:  Common molecule fragments for visualization in Avogadro
debuginfod:  Handle ELF object files and DWARF debugging information (debuginfod)
fcitx5-pinyin-zhwiki:  Fcitx 5 Pinyin Dictionary from zh.wikipedia.org
haskell-ghc-api-compat:  GHC-API compatibility helpers
himalaya:  Minimalist CLI email client
libcolord:  System daemon for managing color devices (client library)
linux510-rt:  The Linux510-rt kernel and modules
linux510-rt-acpi_call:  A linux kernel module that enables calls to ACPI methods through /proc/acpi/call
linux510-rt-bbswitch:  kernel module allowing to switch dedicated graphics card on Optimus laptops
linux510-rt-broadcom-wl:  Broadcom 802.11 Linux STA wireless driver BCM43142.
linux510-rt-headers:  Header files and scripts for building modules for Linux510-rt kernel
linux510-rt-nvidia:  NVIDIA drivers for linux.
linux510-rt-nvidia-390xx:  NVIDIA drivers for linux.
linux510-rt-r8168:  A kernel module for Realtek 8168 network cards
linux510-rt-rtl8723bu:  A kernel module for Realtek 8723bu network cards
linux510-rt-tp_smapi:  Modules for ThinkPad s SMAPI functionality
linux510-rt-vhba-module:  Kernel module that emulates SCSI devices
linux510-rt-virtualbox-host-modules:  Host kernel modules for VirtualBox
linux510-rt-zfs:  Kernel modules for the Zettabyte File System.
linux-rt-lts-manjaro-nvidia:  NVIDIA drivers for linux.
linux-rt-lts-manjaro-zfs:  Kernel modules for the Zettabyte File System
linux-rt-manjaro-nvidia-390xx:  NVIDIA drivers for linux.
linux-rt-manjaro-zfs:  Kernel modules for the Zettabyte File System.
matray:  A Manjaro Linux announcements notification app
minisat:  A minimalistic and high-performance SAT solver
ocaml-ppx_derivers:  Shared deriving plugin registry
phrase-pinyin-data:  Pinyin Data for Phrases
pinyin-data:  Pinyin Data for Hanzi
pypinyin:  Chinese characters transliteration module and tool
pyright:  Type checker for the Python language
python-alt-pytest-asyncio:  Alternative pytest plugin to pytest-asyncio
python-dict2xml:  Small utility to convert a python dictionary into an XML string
python-fabulous:  Print images, colors, and stylish text to the terminal with Python
python-getkey:  Python library to easily read single chars and key strokes
python-nest-asyncio:  Patch asyncio to allow nested event loops
python-noseofyeti:  A custom pyton codec that provides an RSpec style dsl for python
python-pynetbox:  NetBox API client library
qca-qt5:  Qt Cryptographic Architecture
qca-qt6:  Qt Cryptographic Architecture
rime-pinyin-zhwiki:  Fcitx 5 Pinyin Dictionary from zh.wikipedia.org
stp:  Simple Theorem Prover
ttc-iosevka-ss18:  Typeface family designed for coding, terminal use and technical documents. (Ss18 variant)
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#2Messageil y a 1 mois

Bonjour,
Dans le tableau de bord, pamac m'annonce une maj de 132 paquets mais quand je passe par pacman comme j'ai l'habitude de faire pour mes maj, ça me donne :

sudo pacman -Syu
[sudo] Mot de passe de jean-luc : 
:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
:: Début de la mise à jour complète du système…
:: Remplacer lib32-libcanberra-pulse par multilib/lib32-libcanberra ? [O/n] o
:: Remplacer libcanberra-pulse par extra/libcanberra ? [O/n] o
avertissement : pamac-cli : la version locale (10.1.2-0.1) est plus récente que extra (10.0.6-2)
avertissement : pamac-common : la version locale (10.1.2-0.1) est plus récente que extra (10.0.6-2)
avertissement : pamac-gtk : la version locale (10.1.2-0.1) est plus récente que extra (10.0.6-2)
avertissement : pamac-snap-plugin : la version locale (10.1.2-0.1) est plus récente que extra (10.0.6-2)
:: Remplacer qca par extra/qca-qt5 ? [O/n] o
résolution des dépendances…
recherche des conflits entre paquets…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de lib32-libcanberra (0.30+2+gc0620e4-4) casse la dépendance « lib32-libcanberra=0.30+2+gc0620e4-3 » requise par lib32-libcanberra-gstreamer
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-gstreamer
Que dois-je faire ?

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#3Messageil y a 1 mois

MAJ de 380 paquets sous Cinnamon sans problème particulier.

Depuis 3 MAJ, la version de java n'est pas passée à la version 16 dans community. Seul un paquet AUR existe.
Cette version est nécessaire à maj de Cryptomator. :siffle

Une nouvelle maj est annoncée sur l'inter : majaroUS

Aie C'était la précédente. :o:roll::bon:

Mntray est supprimé mais remplacé par Matray du ............même auteur. J'ai découvert cette appli par hasard il y a une semaine environ et je dois dire que c'est bien pratique d'avoir les notifications de l'inter directement sur le bureau.
Dernière modification par Cenwenil y a 1 mois, modifié au total 1 fois.

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#4Messageil y a 1 mois

bonjour

Je suppose que tu peux les dé-installer avant maj (mon miroir n'indique pas encore de maj)

sudo pacman -Rdd libcanberra-gstreamer libcanberra-pulse lib32-libcanberra-gstreamer lib32-libcanberra-pulse      
ps: possible de ne pas avoir les lib32-** d'installés chez nous, ni libcanberra-pulse :wink:
ps: ces dé-installations sauvages vont créer normalement quelques orphelins après mise à jour

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#5Messageil y a 1 mois

Nouvelle maj du jour, 141 paquets sur gnome :bien

Pour le soucis des libs canberra avec pacman -> soit les delete avant la maj, soit passer par pamac

sudo pamac update
et ça roule !

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#6Messageil y a 1 mois

Attention Quelques "Kernel Panic" remontent à l'inter au reboot après cette mise à jour - pas encore assez de retours pour voir pourquoi certains sont touchés

EDIT : problème trouvé : MkInitCpio pour tous les noyaux plus petit que 5.10
Philm a écrit :MkInitCpio issue I’ve to fix. We don’t have all kernels supporting zstd compression by default.
et corrigé : le paquet mkinitcpio 30-2 n'utilise plus par défaut zstd:pompom:

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#7Messageil y a 1 mois

Etant spécialiste des trucs bizarres en matière de mise à jour :maisnon: , je vais un peu patienter avant de me lancer! :lol:

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#8Messageil y a 1 mois

papajoke a écrit : il y a 1 mois bonjour

Je suppose que tu peux les dé-installer avant maj (mon miroir n'indique pas encore de maj)

sudo pacman -Rdd libcanberra-gstreamer libcanberra-pulse lib32-libcanberra-gstreamer lib32-libcanberra-pulse      
ps: possible de ne pas avoir les lib32-** d'installés chez nous, ni libcanberra-pulse :wink:
ps: ces dé-installations sauvages vont créer normalement quelques orphelins après mise à jour
OK merci c'est fait... et maj sous KDE Plasma réussi... et redémarrage sans problème :bien

La suppression de ces 4 paquets dont libcanberra-pulse va-t-elle nous priver de quelque chose ?

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#9Messageil y a 1 mois

privé de rien car c'était des dépendances "obligatoires" et non optionnelles, pacman lors de la maj a bien reconstruit les dépendances que nous venions de briser ! maintenant nous avons libcanberra la remplaçante des 2

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#10Messageil y a 1 mois

papajoke a écrit : il y a 1 mois bonjour

Je suppose que tu peux les dé-installer avant maj (mon miroir n'indique pas encore de maj)

sudo pacman -Rdd libcanberra-gstreamer libcanberra-pulse lib32-libcanberra-gstreamer lib32-libcanberra-pulse      
ps: possible de ne pas avoir les lib32-** d'installés chez nous, ni libcanberra-pulse :wink:
ps: ces dé-installations sauvages vont créer normalement quelques orphelins après mise à jour
Bonsoir et merci, grâce à cela j'ai pu mettre à jour mon Kde.
A part cela nickel après un redémarrage.
Gracias pour cet excellent Travail.

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#11Messageil y a 1 mois

142 paquets KDE mis à jour/installés pour 1,3 go
aucun problème avec la commande

merci à toute l'équipe :pompom:

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#12Messageil y a 1 mois

Bonjour à toutes et tous
114 paquets à mettre à jour , hier , . J'ai quelques erreurs , apparemment comme certains , je vous mets en dessous les manips que j'ai faites

jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Sy
[sudo] Mot de passe de jenmy : 
:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
Je commence toujours par -Sy
Ensuite

[jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Su
:: Début de la mise à jour complète du système…
:: Remplacer lib32-libcanberra-pulse par multilib/lib32-libcanberra ? [O/n] n
:: Remplacer libcanberra-pulse par extra/libcanberra ? [O/n] n
:: Remplacer qca par extra/qca-qt5 ? [O/n] n
résolution des dépendances…
recherche des conflits entre paquets…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de lib32-libcanberra (0.30+2+gc0620e4-4) casse la dépendance « lib32-libcanberra=0.30+2+gc0620e4-3 » requise par lib32-libcanberra-pulse
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-gstreamer
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-pulse
J'ai 2 manips , la 1 , j'accepte les changements
la 2 , je refuse les changements , mais le résultat est le même à chaque fois
J'ai lu dans le fil , qu'il pouvait y avoir un problème de clef , voila 3 ou 4 jours , j'ai eu une grosse MàJ des clefs , plus d'une centaine
Comme je ne suis pas encore trop habitué avec MANJARO , je n'utilise que " pacman" pour faire les MàJ , je vais attendre un peu que le problème soit résolu par les devs , sinon je chercherai dans " Roseta " la façon de verrouiller ces paquets pour qu'ils ne gênent plus le bon déroulement de la MàJ
Bonne journée



Je viens de parcourir le fil pour trouver la solution
administration/modération

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#13Messageil y a 1 mois

janmy a écrit : il y a 1 mois Bonjour à toutes et tous
114 paquets à mettre à jour , hier , . J'ai quelques erreurs , apparemment comme certains , je vous mets en dessous les manips que j'ai faites

jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Sy
[sudo] Mot de passe de jenmy : 
:: Synchronisation des bases de données de paquets…
 core est à jour
 extra est à jour
 community est à jour
 multilib est à jour
Je commence toujours par -Sy
Ensuite

[jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Su
:: Début de la mise à jour complète du système…
:: Remplacer lib32-libcanberra-pulse par multilib/lib32-libcanberra ? [O/n] n
:: Remplacer libcanberra-pulse par extra/libcanberra ? [O/n] n
:: Remplacer qca par extra/qca-qt5 ? [O/n] n
résolution des dépendances…
recherche des conflits entre paquets…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de lib32-libcanberra (0.30+2+gc0620e4-4) casse la dépendance « lib32-libcanberra=0.30+2+gc0620e4-3 » requise par lib32-libcanberra-pulse
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-gstreamer
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-pulse
J'ai 2 manips , la 1 , j'accepte les changements
la 2 , je refuse les changements , mais le résultat est le même à chaque fois
J'ai lu dans le fil , qu'il pouvait y avoir un problème de clef , voila 3 ou 4 jours , j'ai eu une grosse MàJ des clefs , plus d'une centaine
Comme je ne suis pas encore trop habitué avec MANJARO , je n'utilise que " pacman" pour faire les MàJ , je vais attendre un peu que le problème soit résolu par les devs , sinon je chercherai dans " Roseta " la façon de verrouiller ces paquets pour qu'ils ne gênent plus le bon déroulement de la MàJ
Bonne journée







Je viens de parcourir le fil pour trouver la solution
Meme soucis

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#14Messageil y a 1 mois

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#15Messageil y a 1 mois

Merci Jeanluck
Je suis certainement passé pas loin de cette manip , mais sans tilter vraiment . De plus , je pensais plutôt " bloquer " ces paquets pour qu'ils ne s'installent pas , je ne pensais pas les désinstaller
Et dans " Roseta " ,je n'ai pas trouvé l'équivalent à " addlock " de chez SuSE ou " make hold " de Debian
Je ferai cette manip ce soir et rendrai compte après
Bonne journée

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#16Messageil y a 1 mois

janmy a écrit : il y a 1 mois équivalent à " addlock " de chez SuSE
pas de commande pour nous ! Le plus proche est l'édition dans /etc/pacman.conf de la clé IgnorePkg
Mais en fait nous utilisons très très rarement - uniquement après avoir fait un downgrade d'un paquet pour le bloquer temporairement à une version précédente (surtout pas pour un conflit de paquet)
janmy a écrit : il y a 1 mois Je viens de parcourir le fil pour trouver la solution
message déplacé - attention à bien lire/écrire dans la dernière annonce , sinon oui, il est difficile de trouver une info pertinente : chaque maj est différente

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#17Messageil y a 1 mois

Bonsoir Papajoke
Merci pour toutes ces informations , j'en profite pour corriger mon erreur sur Debian , ce n'est pas " make hold " c'est "mark hold " , petite confusion
Je viens de faire un copier /coller de ta ligne de commandes pour supprimer les paquets gênants , sans y regarder de trop près , donc , comme mes " erreurs "ne sont pas les même , il ne trouve rien à supprimer , je l'ai donc fait en manuel , en récupérant les " sources de " mes " conflits , et en les supprimant , comme ci dessous
Rappel des " conflits "
[code Remplacer lib32-libcanberra-pulse par multilib/lib32-libcanberra ? [O/n] n
:: Remplacer libcanberra-pulse par extra/libcanberra ? [O/n] n
:: Remplacer qca par extra/qca-qt5 ? [O/n][/code]
Ensuite , l'un après l'autre , je supprime ces 3 paquets

[jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Rdd lib32-libcanberra-pulse

[jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Rdd libcanberra-pulse

[jenmy@jenmy-celsiusw410 ~]$ sudo pacman -Rdd qca
Voila où j'en suis , je vais maintenant faire les MàJ , si je ne suis pas revenu d'ici 1 heure ,c'est que je suis entrain de réinstaller MANJARO :pleure:

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#18Messageil y a 1 mois

maj gnome 700 mo ras comme dab ,merci mr manjaro :clap:clap

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#19Messageil y a 1 mois

janmy a écrit : il y a 1 mois

 :: Remplacer libcanberra-pulse par extra/libcanberra ? [O/n] n
Petite précision pacman, lorsque pacman propose à la fin [O/n] : la valeur par défaut et la MAJUSCULE, il suffit donc de valider sans valeur :wink:
99 fois sur 100, on garde la valeur par défaut : ici libcanberra-pulse n'existe plus dans no dépôts et est remplacée par libcanberra - répondre non n'est donc certainement pas une bonne façon de faire
janmy a écrit : il y a 1 mois Rappel des " conflits "

:: Remplacer qca par extra/qca-qt5 ? [O/n]
Ce n'est pas un conflit mais ici aussi un paquet disparaît et un autre va le remplacer
donc Oui est aussi la bonne réponse ! ce que tu as fais (par défaut)

un conflit de paquet c'est un message du type
:: l’installation de xxx casse la dépendance yyy(ou xxx-1) requise par zzz
Existe aussi les conflits de fichiers, autre message différent (dans premier message d'annonce)

[Stable] Mise à jour 14/06/2021 - Kernels, Navigateurs, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire

#20Messageil y a 1 mois

Bonsoir,

J'ai fait la màj de mon Manjaro Xfce, après avoir rencontré ce souçis :

erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de lib32-libcanberra (0.30+2+gc0620e4-4) casse la dépendance « lib32-libcanberra=0.30+2+gc0620e4-3 » requise par lib32-libcanberra-pulse
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-gstreamer
:: l’installation de libcanberra (0.30+2+gc0620e4-4) casse la dépendance « libcanberra=0.30+2+gc0620e4-3 » requise par libcanberra-pulse
J'ai fait comme indiqué :

sudo pacman -Rdd libcanberra-gstreamer libcanberra-pulse lib32-libcanberra-gstreamer lib32-libcanberra-pulse
Vaccin apparemment sans effets secondaires (?? est-ce vrai ?) car comme dit Papajoke :
privé de rien car c'était des dépendances "obligatoires" et non optionnelles, pacman lors de la maj a bien reconstruit les dépendances que nous venions de briser ! maintenant nous avons libcanberra la remplaçante des 2
Mais...au re-démarrage avec mon noyau 4.19.193-1 j'ai un écran noir avec :

Image

J'ai re-démarré avec le noyau 5.4.124-1 et là pas de soucis. Mais j'ai besoin d'utiliser le noyau 4.19.193-1 sinon je ne peux pas sortir de veille, comment faire ? A quoi correspondent ces erreurs ?

Merci.
Répondre