Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#1Messageil y a 3 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée
Bonjour la communauté,
Une autre mise à jour de la branche stable avec quelques mises à jour habituelles pour vous.
  • La plupart des noyaux ont été mis à jour
  • Avec cela, nous avons également mis à jour Cinnamon vers la série 5.2. Plus d'infos dans la revue de version
  • kicad est à 6.0.1
  • Lazarus IDE est maintenant à 2.2.0
  • opensearch 1.2.3 a été ajouté
  • Systemd a été renouvelé à 250.2
  • Xorg-Server est maintenant à 21.1.3
  • Mesa a été renouvelé en 21.3.4
  • Le pilote Nvidia est à 495.46
  • Plasma est à 5.23.5 et KDE Gear a été mis à jour vers 21.12.1 - Le framework KDE est maintenant à 5.90.0
  • Nous avons mis à jour Firefox vers 96.0.1 et ajouté Thunderbird à 91.5.0
  • La plupart des pièces Gnome sont maintenant à 41.3
  • LibreOffice a été mis à jour vers 7.2.5
  • PipeWire est maintenant à 0.3.43
  • Avec 7.0rc5 Wine a un autre RC
  • AMDVLK est maintenant au 2021.Q4.3
  • libadwaita est maintenant à 1.0
  • Les mises à jour habituelles en amont, y compris Haskell et Python
N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu
ou encore

sudo pamac update
-------------------------------------------------------------------------------------


Noyaux pris en charge :
  • linux44 4.4.299
  • linux49 4.9.297
  • linux414 4.14.262
  • linux419 4.19.225
  • linux54 5.4.173
  • linux510 5.10.93
  • linux514 5.14.21 [EOL] En fin de vie
  • linux515 5.15.16
  • linux516 5.16.2
  • linux510-rt 5.10.90_rt60
  • linux515-rt 5.15.13_rt26
Les changements en détail :
  • community x86_64: 2060 nouveaux et 1967 paquets retirés
  • core x86_64: 56 nouveaux et 57 paquets retirés
  • extra x86_64: 928 nouveaux et 990 paquets retirés
  • kde-unstable x86_64: 407 nouveaux et 406 paquets retirés
  • multilib x86_64: 31 nouveaux et 33 paquets retirés
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#2Messageil y a 3 mois

Bonjour et merci, mais ...

Je n'ai plus de lecteur video sur mes navigateurs (chromium et firefox), pour la lecture de youtube, dailymotion, netflix, prime
J'commençais à avoir des probleme d'internet avant la mise à jours xD Je ne sais plus quopi penser.
J'essai de revenir actualiser mon statut prochainement.


EDIT (10 min après) : j'ai ajouté le kernel 5.15.16-1 en plus de celui que j'avais : 5.10.93-1, et celà semble résoudre mes problemes
Bien sur, redémarrage necessaire !!! et appairer à nouveau le periphérique bluetooth :p

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#3Messageil y a 3 mois

Bonjour

Il est très rare que j'ai un conflit lors d'une mise à jour.
Mais il faut toujours une exception.
je rencontre cette erreur

la satisfaction des dépendances a échoué:
- impossible de satisfaire la dépendance « python2-py » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-pluggy » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-more-itertools » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-atomicwrites » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-wcwidth » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-funcsigs » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-pathlib2 » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-importlib-metadata » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-setuptools-scm » requise par python2-pytest
- impossible de satisfaire la dépendance « python2-pytest » requise par python2-beautifulsoup4
Transaction annulée.
Je suppose que cela est lié à Calibre.
(https://archlinux.org/packages/communit ... ifulsoup4/)

En conséquence, je me dis qu'il faudrait désinstaller python2-test ou désinstaller Calibre. Et réinstaller une fois la mise à jour effectuer.
Est-ce que vous pensez que c'est une bonne option ? Et selon vous, Calibre d'abord ou python2-test ?
Merci
bon courage

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#4Messageil y a 3 mois

tu peux donner le retour de

pacman -Qoq /usr/lib/python3.9

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#5Messageil y a 3 mois

bien sûr

pacman -Qoq /usr/lib/python3.9
erreur : aucun paquet ne contient /usr/lib/python3.9

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#6Messageil y a 3 mois

Salut,
patrickm a écrit : il y a 3 mois Je suppose que cela est lié à Calibre.
(https://archlinux.org/packages/communit ... ifulsoup4/)

En conséquence, je me dis qu'il faudrait désinstaller python2-test ou désinstaller Calibre. Et réinstaller une fois la mise à jour effectuer.
Est-ce que vous pensez que c'est une bonne option ? Et selon vous, Calibre d'abord ou python2-test ?
Calibre utilise des paquets python 3, non des paquets python 2, tes problèmes de dépendances viennent apparemment de paquets qui ont disparus de AUR, on peut les voir en rouge ici :
https://aur.archlinux.org/packages/python2-pytest/

et ici :
https://aur.archlinux.org/packages/pyth ... ifulsoup4/

Pour connaitre le ou les paquets dépendants de python2-beautifulsoup4 essaie cette commande :

pactree -r python2-beautifulsoup4

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#7Messageil y a 3 mois

Maj faite: RAS au premier abord.

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#8Messageil y a 3 mois

Hi :salut:

169 paquets sous xfce + kernel 5.16 RAS :bien

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#9Messageil y a 3 mois

Smurf a écrit : il y a 3 mois Pour connaitre le ou les paquets dépendants de python2-beautifulsoup4 essaie cette commande :

pactree -r python2-beautifulsoup4
Il n'y a que le paquet en lui-même.

pactree -r python2-beautifulsoup4
python2-beautifulsoup4

je suppose donc que je peux supprimer pytest.

m'y attelle ce soir
merci :)

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#10Messageil y a 3 mois

Salut, maj de 321 paquets sous KDE Plasma er redémarrage sans problème :bien

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#11Messageil y a 3 mois

Sous Mate un pc et le mac de ma femme mis à jour. Aucun souci à reporter.

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#12Messageil y a 3 mois

:bjr: Tout le monde

321 paquets (1.4 Go) pour Kde et redémarrage impéccable
:bien et :merci:

Michel

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#13Messageil y a 3 mois

:bjr:
Juste pour dire qu'après toutes ces années passées avec Manjaro, je suis toujours épaté par la rapidité (aujourd'hui 80 Mb/s, merci les serveurs) et la fiabilité globale des mises à jour, pour peu qu'on fasse un peu attention.

Bravo Manjaro ! :clap

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#14Messageil y a 3 mois

maj sous kde ras

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#15Messageil y a 3 mois

Bonjour, :salut:

Maj de 425 paquets sous Cinnamon Ras sauf pour la partie AUR de virtualbox (a pas fait attention au numero de version). Un soucis pour mettre 3 applis à jour de AUR (git-cola, liquidctl-git et python2-cparser...). Pourtant il n'y a pas d'appli python en 3.9. :saispas:
Maj de 452 paquets sous kde. Ras.

[Stable] Mise à jour 23/01/2022 - Kernels, KDE, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

#16Messageil y a 3 mois

patrickm a écrit : il y a 3 mois je suppose donc que je peux supprimer pytest.
finalement, j'ai supprimé les paquets orphelins
et la mise à jour est passée comme une lettre à la poste (l'expression est un peu datée, je sais :))

merci pour votre aide et vos conseils :)
ça m'a permis d'y voir plus clair

edit
en fait, c'est plus pervers ou plus simple que ça : considérer la différence entre pacman et pamac. L'un met à jour les paquets officiels, l'autre inclue la mise à jour des paquets AUR. Bref, après suppression du paquet bellesoupe, les paquets AUR ont également été mis à jour.
:bien
Répondre