Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#1Messageil y a 1 semaine

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée
Bonjour la communauté,
une autre mise à jour stable de la branche avec quelques mises à jour habituelles pour vous.
  • Linux 5.18
  • Linux 5.19-rc1
  • Systemd 251. Il y a eu beaucoup de changements majeurs. La version minimale du noyau requise est passée de 3.13 à 4.15. Cela signifie bien sûr que Manjaro a abandonné les noyaux 4.9 et 4.14 LTS .
  • GNOME 42.2
  • Mesa 22.1.0
  • Pilote NVIDIA 515.48.07 (branche de production)
  • Mesa 22.1.1
  • PulseAudio 16.0
  • PipeWire 0.3.52
  • Perl 5.36.0
  • Pamac a obtenu un nouveau point-release . De plus, sa bibliothèque a reçu des améliorations et des correctifs
  • LibreOffice 7.3.4
  • Publication de KDE Gear 22.04.2 ont été publiées
  • Mises à jour quotidiennes de KDE-git
  • Quelques mises à jour régulières de Haskell et Python

Détail de la liste des paquets pour cette mise à jour (attention, c'est très long !)
https://lists.manjaro.org/pipermail/man ... 606/049502

Tout a été recompilé pour la montée de GCC, systemd et LLVM

Avant d'effectuer la maj, faire une vérification de

cat /etc/locale.gen
il va être sauvegardé sous

/etc/locale.gen.pacsave 
si vous rencontrez des soucis d'affichage dans le terminal de nouveau caractères parasites ou erreur

sudo mv /etc/locale.conf.pacsave /etc/locale.conf
voir ce sujet
https://forum.manjaro.org/t/testing-upd ... mac/113093

Systemd 251. Il y a eu beaucoup de changements majeurs. La version minimale du noyau requise est passée de 3.13 à 4.15. Cela signifie bien sûr que Manjaro a abandonné les noyaux 4.9 et 4.14 LTS dans immédiat.

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu
ou encore

sudo pamac update
-------------------------------------------------------------------------------------


État des miroirs actuellement :


Noyaux pris en charge :
  • linux419 4.19.246
  • linux54 5.4.197
  • linux510 5.10.121
  • linux515 5.15.46
  • linux517 5.17.14
  • linux518 5.18.3
  • linux519 5.19-rc1
  • linux515-rt 5.15.44_rt46
  • linux518-rt 5.18.0_rt11
78 paquets supprimés (linux414 , linux48 et linux517-rt):

apm aspnet-runtime-3.1 aspnet-targeting-pack-3.1 atom dotnet-runtime-3.1 dotnet-sdk-3.1 dotnet-targeting-pack-3.1 geda-gaf gn-m85 guile2.0 i810-dri lib32-mangohud-wayland lib32-mangohud-x11 libfirmware-manager libstroke linux414 linux414-acpi_call linux414-bbswitch linux414-broadcom-wl linux414-headers linux414-ndiswrapper linux414-nvidia linux414-nvidia-390xx linux414-nvidia-470xx linux414-nvidiabl linux414-r8168 linux414-rt3562sta linux414-rtl8723bu linux414-tp_smapi linux414-vhba-module linux414-virtualbox-host-modules linux414-zfs linux49 linux49-acpi_call linux49-bbswitch linux49-broadcom-wl linux49-headers linux49-ndiswrapper linux49-nvidia linux49-nvidia-390xx linux49-nvidia-470xx linux49-nvidiabl linux49-r8168 linux49-rt3562sta linux49-rtl8723bu linux49-tp_smapi linux49-vhba-module linux49-virtualbox-host-modules linux49-zfs linux517-rt linux517-rt-acpi_call linux517-rt-bbswitch linux517-rt-broadcom-wl linux517-rt-headers linux517-rt-nvidia linux517-rt-nvidia-390xx linux517-rt-nvidia-470xx linux517-rt-tp_smapi linux517-rt-vhba-module linux517-rt-virtualbox-host-modules mach64-dri mangohud-common-wayland mangohud-common-x11 mangohud-wayland mangohud-x11 mediawiki-math mga-dri nimble nodejs-lts-erbium penguins-eggs python-jaraco qliveplayer r128-dri savage-dri sis-dri tdfx-dri trojita unichrome-dri
86 nouveaux paquets (linux519 et linux518-rt):

auth-tarball-from-git        Authenticate a tarball through a signed tag in a git repository (with reproducible builds) https://github.com/kpcyrd/auth-tarball-from-git
bearssl                      Implementation of the SSL/TLS protocol (RFC 5246) written in C https://bearssl.org
bigsh0t                      A collection of frei0r plugins for VR video, with support for Shotcut https://bitbucket.org/leo_sutic/bigsh0t
cargo-hakari                 Manage workspace-hack packages to speed up builds in large workspaces https://github.com/facebookincubator/cargo-guppy
check-sieve                  Syntax checker for Sieve scripts https://github.com/dburkart/check-sieve
cl-asdf-flv                  cl-asdf extension to provide support for file-local variables https://github.com/didierverna/asdf-flv
cl-babel                     A charset encoding/decoding library for Common Lisp https://babel.common-lisp.dev/
cl-bordeaux-threads          Portable shared-state concurrency for Common Lisp https://sionescu.github.io/bordeaux-threads/
cl-cffi                      Common Foreign Function Interface for Common Lisp https://cffi.common-lisp.dev/
cl-clx                       An implementation of the X Window System protocol in Common Lisp https://github.com/sharplispers/clx
cl-fiveam                    A regression testing framework for Common Lisp https://fiveam.common-lisp.dev
cl-global-vars               Define efficient global variables in Common Lisp https://github.com/lmj/global-vars
cl-hu-dwim-stefil            A simple test framework in Common Lisp https://github.com/hu-dwim/hu.dwim.stefil
cl-json                      JSON encoder/decoder for Common Lisp https://cl-json.common-lisp.dev/cl-json.html
cl-lift                      The LIsp Framework for Testing https://lift.common-lisp.dev
cl-trivial-backtrace         Portable API to work with backtraces in Common Lisp https://github.com/gwkkwg/trivial-backtrace
cl-trivial-features          Ensure consistent features across multiple Common Lisp implementations https://github.com/trivial-features/trivial-features
cl-trivial-garbage           Portable Garbage Collection related APIs for Common Lisp https://trivial-garbage.common-lisp.dev/
crosstool-ng                 A versatile (cross-)toolchain generator https://crosstool-ng.github.io/
ghc-filesystem               An implementation of C++17 std::filesystem for C++11 /C++14/C++17/C++20 https://github.com/gulrak/filesystem
gmni                         A Gemini client https://git.sr.ht/~sircmpwn/gmni
gnome-control-center-x11-scaling GNOME main interface to configure various aspects of the desktop with X11 fractional scaling patch https://gitlab.gnome.org/GNOME/gnome-control-center
gss                          GNU Generic Security Service https://www.gnu.org/software/gss/
haskell-monad-parallel       Parallel execution of monadic computations https://hub.darcs.net/blamario/SCC.wiki/
httplz                       Host These Things Please - a basic http server for hosting a folder fast and simply https://github.com/thecoshman/http
libiconv                     GNU charset conversion library http://www.gnu.org/software/libiconv/
libverto                     Main event loop abstraction library https://github.com/latchset/libverto
linux518-bbswitch            kernel module allowing to switch dedicated graphics card on Optimus laptops http://github.com/Bumblebee-Project/bbswitch
linux518-broadcom-wl         Broadcom 802.11 Linux STA wireless driver BCM43142. https://bbs.archlinux.org/viewtopic.php?id=145884
linux518-nvidia-390xx        NVIDIA drivers for linux http://www.nvidia.com/
linux518-r8168               A kernel module for Realtek 8168 network cards http://www.realtek.com.tw
linux518-virtualbox-host-modules Host kernel modules for VirtualBox http://virtualbox.org
linux518-zfs                 Kernel modules for the Zettabyte File System. http://zfsonlinux.org/
linux518-rt                  The Linux518-rt kernel and modules https://www.kernel.org
linux518-rt-***
linux519                     The Linux519 kernel and modules https://www.kernel.org/
linux519-***
mangoapp                     A transparent background OpenGL application with a built-in MangoHud designed to be run inside a gamescope instance https://github.com/flightlessmango/MangoHud
mangohud                     A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more. https://github.com/flightlessmango/MangoHud
nix-busybox                  Slimmed down busybox for Nix sandbox builds https://www.busybox.net
noise-suppression-for-voice  A real-time noise suppression plugin for voice https://github.com/werman/noise-suppression-for-voice
p2pool                       Decentralized pool for Monero mining https://github.com/SChernykh/p2pool
pnpm                         Fast, disk space efficient package manager https://pnpm.io
python-calver                Setuptools extension for CalVer package versions https://github.com/di/calver
python-jaraco.classes        Module for classes manipulation https://github.com/jaraco/jaraco.classes
python-jaraco.collections    Models and classes to supplement the stdlib 'collections' module. https://github.com/jaraco/jaraco.collections
python-jaraco.functools      Functools like those found in stdlib https://github.com/jaraco/jaraco.functools
python-jaraco.itertools      Itertools for Python https://github.com/jaraco/jaraco.itertools
python-jaraco.logging        Quickly solicit log level info from command-line parameters https://github.com/jaraco/jaraco.logging
python-jaraco.stream         Routines for handling streaming data https://github.com/jaraco/jaraco.stream
python-jaraco.text           Module for text manipulation https://github.com/jaraco/jaraco.text
python-nspektr               A distribution package dependency inspector https://github.com/jaraco/nspektr
python-psycopg               PostgreSQL database adapter for Python https://www.psycopg.org/psycopg3/
python-psycopg-pool          Connection pool for psycopg https://www.psycopg.org/psycopg3/
python-rstcheck-core         Checks syntax of reStructuredText and code blocks nested within it https://github.com/rstcheck/rstcheck
python-sphinx-basic-ng       Modernised skeleton for Sphinx themes https://github.com/pradyunsg/sphinx-basic-ng
python-sphinx-reredirects    Handles redirects for moved pages in Sphinx documentation projects https://gitlab.com/documatt/sphinx-reredirects
python-trove-classifiers     Canonical source for classifiers on PyPI (pypi.org) https://github.com/pypa/trove-classifiers
python-validate-pyproject    Validation library and CLI tool for checking on 'pyproject.toml' files using JSON Schema https://github.com/abravalheri/validate-pyproject
qhexedit2                    Hex editor widget written in C++ for the Qt framework https://github.com/Simsys/qhexedit2
roswell                      Environment for Common Lisp development https://roswell.github.io
ruby-minitest-power_assert   Power Assert for Minitest https://github.com/hsbt/minitest-power_assert
sfsexp                       Small Fast S-Expression Library https://github.com/mjsottile/sfsexp
stb                          Single-file public domain (or MIT licensed) libraries for C/C++ https://github.com/nothings/stb
stumpwm                      Tiling, keyboard-driven window manager written in Common Lisp https://stumpwm.github.io/
topcom                       A package for computing Triangulations Of Point Configurations and Oriented Matroids https://www.wm.uni-bayreuth.de/de/team/rambau_joerg/TOPCOM/index.html
-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------
Dernière modification par stephaneil y a 1 semaine, modifié au total 2 fois.

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#2Messageil y a 1 semaine

mise à jour de KDE Manjaro réussie.
J'attendais avec impatience la version 1.2 de Inkscape.
Un site en français détaillant les nouveautés :
http://www.ds-inkscape.net/
D'autre part, la fonction zoom a enfin été remise dans la barre d'outil !

A vos souris !

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#3Messageil y a 1 semaine

Bonjour tout le monde

432 paquets pour Kde et redémarrage avec un problème : Kontact "L'environnement Akonadi de gestion des informations personnelles n'est pas opérationnel"
je n'ai plus de courriel, de calendrier ......
J'ai redémarré 2 fois sans succès . :rendre:
Si quelqu'un a une idée, merci d'avance

Michel

PS : Quand j'essaye Akonadi console j'ai ce message:
Failed to connect to database: Can't connect to local server through socket '/run/user/1000/akonadi/mysql.socket' (2) QMYSQL: Impossible de se connecter

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#4Messageil y a 1 semaine

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#5Messageil y a 1 semaine

Bonjour, maj de 320 paquets sous KDE, redémarrage sans souci... :clap

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#6Messageil y a 1 semaine

Chez moi idem, et en moins de 10mns, chose rare! Reste à faire le portable.
Merci à toute l'équipe de la team Manjaro! :merci:

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#7Messageil y a 1 semaine

@ Imarco
j'ai vraiment mal cherché :maisnon:
Merci à toi pour ton message
Tout est OK

Michel

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#8Messageil y a 1 semaine

Bonjour,
Mise à jour sans soucis sous gnome. Après redémarrage, tout est OK.
Merci et :clap

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#9Messageil y a 1 semaine

400 paquets KDE pour 1,1 Go.
aucun problème ;)
merci :pompom:

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#10Messageil y a 1 semaine

Aucun soucis de mon coté.
Passage en 5.18.3-1 en même temps et tout fonctionne.
Merci

[Stable]Mise à jour 12/06/2022 Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire

#11Messageil y a 1 semaine

Bonjour à tous,
MAJ sans soucis de mon côté sous Gnome.
Merci à l'équipe
Répondre