Actualités & Annonces de l'équipe de développement et des administrateurs du forum.
Répondre

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#1Messageil y a 1 mois

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée

Bonjour la communauté.

Une autre mise à jour de la branche stable pour vous.
  • Certains de nos noyaux ont été mis à jour
  • Firefox est à 102.0
  • Thunderbird a été renouvelé en 91.11.0
  • Les pilotes Nvidia ont été mis à jour vers 515.57
  • Mises à jour régulières de Haskell et Python

N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu
ou encore

sudo pamac update
-------------------------------------------------------------------------------------


État des miroirs actuellement :


Noyaux pris en charge :
  • linux419 4.19.249
  • linux54 5.4.201
  • linux510 5.10.126
  • linux515 5.15.50
  • linux517 5.17.15 (EOL) En fin de vie
  • linux518 5.18.7
  • linux519 5.19-rc4 (expérimental)
  • linux515-rt 5.15.49_rt47
  • linux518-rt 5.18.0_rt11
Les changements en détail :
  • community x86_64: 414 nouveaux et 406 paquets retirés
  • core x86_64: 20 nouveaux et 20 paquets retirés
  • extra x86_64: 114 nouveaux et 213 paquets retirés
  • kde-unstable x86_64: 311 nouveaux et 310 paquets retirés
  • multilib x86_64: 15 nouveaux et 15 paquets retirés
Une liste détaillée des changements est disponible ici

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#2Messageil y a 1 mois

Bonjour, maj de 31 paquets et redémarrage sans problème sous KDE :clap

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#3Messageil y a 1 mois

Une petite quarantaine et RAS.

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#4Messageil y a 1 mois

:salut: à tous
Problème de compatibilté de librairies qt persistant pour moi depuis la dernière MAJ...

Cannot mix incompatible Qt library (5.15.3) with this library (5.15.5)
Abandon (core dumped)
non résolue par la recompilation de qt5-styleplugin... je vieillis... :pappy: J'ai du louper un truc! :dormir:
Finalement problème réglé, solution ici : viewtopic.php?p=144003#p144003
Bonne nuit à tous :dormir:
Dernière modification par Grain de sableil y a 1 mois, modifié au total 1 fois.

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#5Messageil y a 1 mois

Sous Mate deux pc (dont un Mac) mis à jour sans difficulté.

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#6Messageil y a 1 mois

mise à jour fluide :)
j'e ai profité pour virer les orphelins inutiles

merci :biere:

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#7Messageil y a 1 mois

patrickm a écrit : il y a 1 mois mise à jour fluide :)
j'e ai profité pour virer les orphelins inutiles

merci :biere:
j'en profite pour poser la question, j'ai une belle petite liste d'orphelins... flème de les faire adopter je voudrais les supprimer... comment être totalement sur qu'un orphelin est inutile ??

Désolé pour la blague de mauvaise goût... :tetu!:tetu!

Néanmoins la question est sérieuse.

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#8Messageil y a 1 mois

Matt_44 a écrit : il y a 1 mois
patrickm a écrit : il y a 1 mois mise à jour fluide :)
j'e ai profité pour virer les orphelins inutiles

merci :biere:
j'en profite pour poser la question, j'ai une belle petite liste d'orphelins... flème de les faire adopter je voudrais les supprimer... comment être totalement sur qu'un orphelin est inutile ??

Désolé pour la blague de mauvaise goût... :tetu!:tetu!

Néanmoins la question est sérieuse.
Bonjour.
Un paquet orphelin est un paquet qui a été installé comme dépendance ou requis par un autre paquet. Lors des différentes mises à jour ou lors de la désinstallation du paquet <maître>, le paquet requis devient orphelin . En théorie, ça ne pose pas de problème pour les virer, mais il arrive que ces paquets orphelins peuvent avoir une utilité . Dans ce cas il faut les déclarer 'explicite' pour les sortir de leur statut d'orphelins.

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#9Messageil y a 1 mois

lemust83 a écrit : il y a 1 mois
Matt_44 a écrit : il y a 1 mois
patrickm a écrit : il y a 1 mois mise à jour fluide :)
j'e ai profité pour virer les orphelins inutiles

merci :biere:
j'en profite pour poser la question, j'ai une belle petite liste d'orphelins... flème de les faire adopter je voudrais les supprimer... comment être totalement sur qu'un orphelin est inutile ??

Désolé pour la blague de mauvaise goût... :tetu!:tetu!

Néanmoins la question est sérieuse.
Bonjour.
Un paquet orphelin est un paquet qui a été installé comme dépendance ou requis par un autre paquet. Lors des différentes mises à jour ou lors de la désinstallation du paquet <maître>, le paquet requis devient orphelin . En théorie, ça ne pose pas de problème pour les virer, mais il arrive que ces paquets orphelins peuvent avoir une utilité . Dans ce cas il faut les déclarer 'explicite' pour les sortir de leur statut d'orphelins.

Merci le must, mais justement comment savoir quel orphelin est utile dans cette long liste ?

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#10Messageil y a 1 mois

j'ai une belle petite liste d'orphelins... flème de les faire adopter je voudrais les supprimer...
.
Attention, ne pas confondre paquets orphelins sur notre système et paquets marqués orphelins dans AUR. Dans ce cas, c'est que le mainteneur abandonne le maintient du paquet en espérant que quelqu'un le reprenne.
En gros, il n'y a pas de règles absolue. Ce que je préconiserais serait de lister les orphelins avec pacman -Qdt >orphelins.txt histoire d'en avoir une liste.
Ensuite, tu vire tout:

sudo pacman -Rs $(pacman -Qdtq)
Si tu rencontres des soucis après la suppression des orphelins et que tu n'as pas vidé le cache de pacman, tu pourras aisément réinstaller le paquet manquant avec sudo pacman -U /var/cache/pacman/pkg/<paquet.tar.zst>

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#11Messageil y a 1 mois

Ok merci. Et existe il une commande permettant d'extraire directement de la liste les orphelin d'aur pour etre sur de ne pas casser mes appli ?


La première commande pour lister ne me donne rien, on dirait qu'elle ne fonctionne pas. Lors de la seconde, je ne suis pas allé plus loin car il y avait quand même 1 go a supprimer et de truc correspondant a virtual box...

[Stable] Mise à jour 04/07/2022 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

#12Messageil y a 4 semaines

@mat_44
tu peux créer un toppic spécifique lrelatif a ce sujet :
dans un premier temps fourni la liste de pacman -Qdt
Répondre