Questions sur l'installation et la configuration de Manjaro Linux.

Problème avec rtx 2060 et gdm

#21Messageil y a 1 semaine

j'ai redémarré. J'ai réactivé le log en début de session et j'ai toujours l'écran qui s'éteint environ 1 min avant que la session gnome ne s'ouvre.
Du coup je l'ai re désactivé

Problème avec rtx 2060 et gdm

#22Messageil y a 1 semaine

tu utilise bien gnome en version X11 ? ( et pas wayland )

Problème avec rtx 2060 et gdm

#23Messageil y a 1 semaine

oui c'est bien X11 j'avais vérifié en faisant

echo "$XDG_SESSION_TYPE"
et j'ai bien X11 en réponse
Dernière modification par Lionelil y a 1 semaine, modifié au total 1 fois.

Problème avec rtx 2060 et gdm

#24Messageil y a 1 semaine

question supplémentaire :
tus des package orphelins ?

pacman -Qdt 

Problème avec rtx 2060 et gdm

#25Messageil y a 1 semaine

oui j'ai

autoconf 2.71-1
automake 1.16.5-1
bison 3.8.2-4
flex 2.6.4-3
make 4.3-3
patch 2.7.6-8
pkgconf 1.8.0-1

Problème avec rtx 2060 et gdm

#26Messageil y a 1 semaine

rien qui concerne gnome ou xorg ou wayland

mon avis : pb vient de gdm qui ne parvient pas a tenir le temps necessaire pour la connexion driver nvidia
tu utilise un ou plusieurs ecrans ?
la connectique utilisée est DVI / HDMI / DP ?
Dernière modification par stephaneil y a 6 jours, modifié au total 1 fois.

Problème avec rtx 2060 et gdm

#27Messageil y a 1 semaine

j'aurais du préciser effectivement mon écran a une connectique VGA et j'ai au bout ujn convertisseur dvi-d vers VGA 60 Hz. Mais j'avais tout de suit pensé à ça et j'avais essayé de brancher l'ordi sur un écran en hdmi directement (la télé) et j'avais exactement le même problème pour accéder à la session gnome après le log dans gdm. Mais comme s'était durant l'install et que j'ai un peu galéré avec ma vieille iso de Manjaro, je vais retenter le coup pour être sur

Problème avec rtx 2060 et gdm

#28Messageil y a 1 semaine

oui, c'est confirmé. J'ai bien le même problème en hdmi et l'écran télé me signale pendant la 1 min d'attente entre le log sur gdm et l'accès à la session gnome : aucune source

Problème avec rtx 2060 et gdm

#29Messageil y a 1 semaine

en tout cas merci pour le temps que tu passes à m'aider

Problème avec rtx 2060 et gdm

#31Messageil y a 6 jours

c'est gdm , le gestionnaire des services , par gnome
Dernière modification par stephaneil y a 6 jours, modifié au total 1 fois.

Problème avec rtx 2060 et gdm

#32Messageil y a 6 jours

Ah oui, retour à la case départ.
Et d'ailleurs la résolution de l'écran n'avait pas bien été reconnu après l'install et j'ai du la changer dans les paramètres gnome, mais la nouvelle résolution n'est pas prise en compte par gdm.
Avec mon ancienne carte graphique (gtx 660) je n'avait pas la bonne résolution non plus au départ et la bonne ne m'était même pas proposée dans les params de gnome. Du coup je l'ai fait manuellement dans l'interface Nvidia x server settings et enregistré pour créer un fichier de conf. Et là gdm avait pris en compte la bonne résolution. J'ai essayé avec ma nouvelle carte graphique de modifier la résolution en passant par Nvidia x server settings mais quand je sauve la nouvelle résolution n'est pas prise en compte (j'ai bien lancé Nvidia x server settings en sudo) ni dans gdm ni dans gnome.

Problème avec rtx 2060 et gdm

#33Messageil y a 5 jours

J'ai activé la journalisation de gdm mais je n'ai pas de log dans

var/log/gdm
J'ai aussi remarqué qu'il y a comme des sortes de lignes verticales sur l'écran de connection de gdm. Je me demande s'il n'y a pas un problème dans l'ordre de chargement des modules avant gdm. Le driver de la carte graphique n'est peut-être pas chargé ?
Je ne sais pas comment vérifier ces paramètres

Problème avec rtx 2060 et gdm

#34Messageil y a 4 jours

En lisant arch wiki concernant le driver Nvidia, je me rend compte que je tombe probablement dans le cas ou il faut activer le DRM dans le kernel mode Setting et même sans doute faire un early loading dans inintramfs. J'ai un peu regardé la méthode. C'est compliqué pour moi. Je vais me contenter d'un démarrage automatique sur la session gnome sans mot de passe dans gdm

Problème avec rtx 2060 et gdm

#35Messageil y a 4 jours

Problème avec rtx 2060 et gdm

#36Messageil y a 3 jours

j'avais essayé d'ajouter nvidia-drm.modeset=1 dans le grub au démarrage en appuyant sur E et je l'avais mis à la fin de la ligne après Linux. Résultat, écran noir et impossible d'arriver à gdm.
C'est vrai aussi que je flippe un peu d'aller tripatouiller le grub. Si je ne peux plus accéder à la session est ce que je pourrai revenir en arrière depuis le live-usb avec la méthode chroot ?
J'imagine que oui, mais je risque d'avoir des sueurs froides !

Problème avec rtx 2060 et gdm

#37Messageil y a 3 jours

Et c'est vrai que je ne suis pas sur que le problème vienne de là. C'est pour ça que j'ai activé la journalisation de gdm. Ca m'a bien créer le dossier /gdm dans var/log/ mais il est vide

Problème avec rtx 2060 et gdm

#38Messageil y a 3 jours

tu as été voir dans le journal ?
( -b0 - démarrage en cours , -1 précédent , - 2 etc... )

sudo journalctl -b0 

Problème avec rtx 2060 et gdm

#39Messageil y a 1 jour

je ne peux pas coller le résultat de

sudo journalctl -b0
c'est plus de 9000 lignes

Problème avec rtx 2060 et gdm

#40Messageil y a 1 jour

Lionel a écrit : il y a 1 jour je ne peux pas coller le résultat de

sudo journalctl -b0
c'est plus de 9000 lignes
Dans ce cas, il faut héberger provisoirement le retour. On crée un fichier texte en local puis on l epousse sur un hébergeur spécialisé dans les retours de code. Ça te retournera un lien que tu nous posteras.
Exemple:

journalctl -b0 > journal.txt
cat journal.txt |curl -F 'f:1=<-' ix.io
http://ix.io/478d
Répondre