Actualités & Annonces de l'équipe de développement et des administrateurs du forum.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#1Messageil y a 2 semaines

Bonjour à toutes et à tous :bjr:

Une mise à jour est annoncée
Bonjour la communauté,
Une autre mise à jour stable de la branche avec quelques mises à jour de packages habituelles pour vous.
Mises à jour notables du package :
  • La plupart des noyaux ont été mis à jour
  • GNOME 43.2
  • Mesa 22.3.3
  • NVIDIA 525.85.05
  • VirtualBox 7.0.6
  • OpenJDK 19.0.2.u7, 11.0.18.u10 et 8.362.u09
  • Framework KDE 5.102.0, KDE (applications) 22.12.1 et Plasma 5.26 avec sa dernière version ponctuelle
  • Libre Office 7.4.4
  • Deepin a beaucoup de packages mis à jour
  • Les packages php ont été mis à jour vers la dernière version 8.2. En plus de cela, un nouvel ensemble de packages php-legacy a été introduit. Voir aussi le billet Arch .
  • Outre les mises à jour habituelles en amont telles que Firefox-Beta , python , haskell et autres, nous avons ajouté nos packages KDE-git comme d'habitude


N'hésitez pas à nous donner vos commentaires sur les modifications apportées aux dépôts.


-------------------------------------------------------------------------------------
Mise à jour possible par pamac, octopi ou par pacman (de préférence) :

sudo pacman -Syu
ou encore

sudo pamac update
-------------------------------------------------------------------------------------


État des miroirs actuellement :


Noyaux pris en charge :
  • linux419 4.19.270
  • linux54 5.4.229
  • linux510 5.10.164
  • linux515 5.15.89
  • linux60 6.0.19 [EOL] En fin de vie
  • linux61 6.1.7
  • linux62 6.2.0rc4
  • linux515-rt 5.15.86_rt56
  • linux60-rt 6.0.5_rt14
Les changements en détail :
  • community x86_64: 2383 nouveaux et 2286 paquets retirés
  • core x86_64: 86 nouveaux et 84 paquets retirés
  • extra x86_64: 1150 nouveaux et 1243 paquets retirés
  • kde-unstable x86_64: 410 nouveaux et 410 paquets retirés
  • multilib x86_64: 56 nouveaux et 53 paquets retirés
Une liste détaillée des changements est disponible ici

-------------------------------------------------------------------------------------


-------------------------------------------------------------------------------------
ERREUR : conflit de fichiers
Si lors de la mise à jour vous avez le type d'erreur comme ci-dessous (tlp est un exemple) :

erreur : la validation de la transaction a échoué (conflit de fichiers)
tlp : /etc/acpi/thinkpad est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
il convient de passer la commande suivante en l'adaptant à votre cas particulier :

sudo pacman -S nom_paquet --overwrite '/etc/acpi/thinkpad'
Ensuite, vous pouvez faire votre mise à jour générale sans problème.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
Problèmes liés à la synchronisation des miroirs

pacman-mirrors || sudo pacman-mirrors --continent; sudo pacman -Syu
Cette commande pacman-mirrorsva analyser le status des miroirs; si OK=> Synchronisation et Mise à jour.
Si KO, pacman-mirrors --continent synchronisera les miroirs les plus proches de votre situation géographique.
Attention si vous utilisez un vpn, dans ce cas, l'option -f0 sera plus appropriée. Ensuite la Mise à jour se lancera normalement.
-------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------
ERREUR de clés

Si lors de la mise à jour vous avez des problèmes de clés, essayez de passer les commandes suivantes :

sudo pacman -Syy
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
Ensuite, vous devriez pouvoir faire votre mise à jour générale sans problème.

-------------------------------------------------------------------------------------

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#2Messageil y a 2 semaines

Une maj apparaît chez moi (469 paquets) mais pas d'annonce même sur le forum inter => je vais attendre un peu. :mrgreen:

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#3Messageil y a 2 semaines

Bonjour

Oui, en effet existe une mise à jour et rien à voir pour l'instant à l'inter (philm a juste fermé la précédente annonce ce matin)
- je l'ai faite ce matin sur 2 machines amd avec kde (360 paquets) et pas de problème :gsourire:
maj apparaît chez moi ... je vais attendre un peu.
Pour rappel, pour ceux qui n'ont pas la fibre, il est possible de télécharger dans le cache de pacman les nouveaux paquets sans mise à jour. Comme cela, la mise à jour, elle, ne téléchargera rien et sera donc beaucoup plus rapide.

checkupdates -d

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#4Messageil y a 2 semaines

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#5Messageil y a 2 semaines

Mise a jour faite sur 4 PC (2 AMD et 2 Intel) tous avec Cinnamon et ...... aucun pb tout roule !!! :cool:
Dernière modification par pat xaranil y a 2 semaines, modifié au total 1 fois.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#6Messageil y a 2 semaines

Salut, nouvelle maj sous KDE et redémarrage sans problème... sauf un bug avec VLC, la fenêtre s'ouvre et se referme aussitôt.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#7Messageil y a 2 semaines

@jeanluck
ras pour moi, sous kde, vlc testé avec 2 codecs est OK :saispas:

EDIT
des retours vlc à l'inter (et chez archlinux) qui semble lié au driver nvidia

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#8Messageil y a 2 semaines

Bonsoir à toutes et tous
363 paquets sous Kde Plasma (2.2Go) , redémarrage ok sauf bug sous vlc , s'ouvre et se referme aussitôt..
J'ai installé la version Flatpak et cela refonctionne.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#9Messageil y a 2 semaines

Ah, tiens une maj. :mrgreen:

RAS sauf 2 petites choses:

pipewire-media-session is deprecated and will soon be removed from the
    repositories. Please use 'wireplumber' instead.
pipewire-media-session est déjà à virer..

Mais aussi:

 Building image from preset: /etc/mkinitcpio.d/linux515.preset: 'default'
  -> -k /boot/vmlinuz-5.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.15-x86_64.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.15-x86_64'
==> Building image from preset: /etc/mkinitcpio.d/linux515.preset: 'fallback'
  -> -k /boot/vmlinuz-5.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.15-x86_64-fallback.img -S autodetect
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.15-x86_64'
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.4-x86_64'
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.4-x86_64'
Erreur: la commande n’a pas pu être exécutée correctement
Je vais réinstaller les noyaux au cas où...

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#10Messageil y a 2 semaines

jeanluck a écrit : il y a 2 semaines Salut, nouvelle maj sous KDE et redémarrage sans problème... sauf un bug avec VLC, la fenêtre s'ouvre et se referme aussitôt.
Même problème VLC chez moi

Réglé en rétrogradant libva
Dernière modification par alex666il y a 2 semaines, modifié au total 1 fois.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#11Messageil y a 2 semaines

Bonjour

RAS sous KDE, virtualbox est en version 7.06-1 ce qui ne me fait plus apparaître les problème de la mise à jour de virtualbox guest additions (en version 7.06-1 alors que virtualbox était toujours en 7.04).
Pour Kdenlilven, Inkscape, Freecad et Cura tout fonctionne.

merci

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#12Messageil y a 2 semaines

586 paquets et 3,5 Go de mise à jour sous KDE et tout est OK :clap:gsourire:

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#13Messageil y a 2 semaines

Bonjour à tous :sourire:
  • Impossible de modifier la luminosité avec Fn+F6 et Fn+F7. Problème qui semble lié au noyau 6.1.* (certains l'ont aussi rencontré sous Arch et Fedora).
    => L'utilisation d'une version précédente − comme la 6.0.* − permet que tout fonctionne.
  • Impossible de lancer certains logiciel Qt (sous Xfce) qui renvoient

    Cannot mix incompatible Qt library (5.15.7) with this library (5.15.8)
    Abandon (core dumped)
    => La suppression du paquet qt5-styleplugins règle l'erreur. Il ne semble plus nécessaire.
Jamais vu une màj aussi lourde : de mémoire ~10 Gio téléchargés, 3 installés.
À ce propos, avant une grosse mise à jour je lance toujours pikaur -Qu pour avoir une vue d'ensemble des paquets et leur changement de version.
Je me demandais si une commande permet de lister les paquets mis à jour avec leur poids téléchargé/installé respectif. Une idée ?

[edit]
J'ai trouvé. Il faut décommenter #VerbosePkgLists dans le fichier /etc/pacman.conf.
VerbosePkgLists
Displays name, version and size of target packages formatted as a table for upgrade, sync and remove operations.
Dernière modification par ⋐ ʟ·ɪɴᴀᴅᴀᴩᴛé ⋑il y a 2 jours, modifié au total 1 fois.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#14Messageil y a 2 semaines

Grosse MAJ ici également.
Pas de souci au final !
Noyau 6.0.19-3, Nvidia 390xx, XFCE.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#15Messageil y a 1 semaine

Aucun ennui après la mise à jour d'un PC et d'un Mac sous MATE.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#16Messageil y a 1 semaine

Mise à jour avec le kernel 5.10 sous XFCE (2 Go de fichiers) -> aucun problème.
Bravo à tous ceux qui nous permettent de profiter d'un système aussi sympa :clap:biere:

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#17Messageil y a 1 semaine

Bonjour,

Le problème VLC a été réglé chez moi en ajoutant dans /etc/environment (solution trouvée sur forum.manjaro.org) :

LIBVA_DRIVER_NAME=nvidia


Mais j'ai un autre problème suite à la mise à jour, que je n'ai pas vu tout de suite. Dans darktable (traitement de photos numériques), le module "lut3d" a disparu. Au démarrage j'ai un message d'erreur :

[iop_load_module] failed to open `lut3d': /usr/lib/darktable/plugins/liblut3d.so: undefined symbol: _ZN12cimg_library8CImgListIcE6assignEj
Ce problème a déjà été référencé, j'en ai trouvé trace ici :
https://github.com/darktable-org/darktable/issues/4220

Il est dit que c'est un bug lié à l'environnement de build, pas à darktable lui-même. J'aimerais le faire remonter mais j'ai un autre problème : je ne trouve pas comment signaler un bug... En consultant https://docs.manjaro.org/reporting-bugs/, il est dit de s'adresser à archlinux pour les paquets upstream (ce qui me semble le cas), mais archlinux refuse de m'enregistrer à cause d'une mauvaise valeur de BUG_REPORT_URL dans /etc/os-release.

Bref, je suis perdu, une aide serait bienvenue...

Alain

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#18Messageil y a 1 semaine

bonjour
aldo a écrit : il y a 1 semaine le module "lut3d" a disparu. Au démarrage j'ai un message d'erreur :

[iop_load_module] failed to open `lut3d': /usr/lib/darktable/plugins/liblut3d.so: undefined symbol: _ZN12cimg_library8CImgListIcE6assignEj
Ce problème a déjà été référencé
ce "module" n'a pas disparu :wink:

sudo pacman -Fy; pacman -F liblut3d.so                                                                                                       ✔ 
community/darktable 2:4.2.0-1
    usr/lib/darktable/plugins/liblut3d.so
Cette librairie est bien dans le paquet actuel en stable
xxxx.so: undefined symbol
Est un message classique en rolling, il nous indique que la bibrairie xxx.so n'est pas à la bonne version.

Puisque, ici ce fichier est inclus dans le paquet, c'est que le paquet n'est pas bon et en effet, il faut remonter le bug au mainteneur du paquet si et uniquement si il n'existe pas déjà une nouvelle version ! et ... chez arch nous avons une autre version.
Si cette nouvelle version arch corrige ce bug, alors on peut demander sur le forum inter que les mainteneurs manjaro fassent une mise à jour de ce paquet directement en stable.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#19Messageil y a 1 semaine

Bonjour,
papajoke a écrit : il y a 1 semaine Si cette nouvelle version arch corrige ce bug, alors on peut demander sur le forum inter que les mainteneurs manjaro fassent une mise à jour de ce paquet directement en stable.
Merci pour tes éclaircissements. Je vais donc attendre la prochaine mise à jour pour voir si le bug est corrigé.

Re: [Stable] Mise à jour 24/12/2022 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

#20Messageil y a 1 semaine

maj de 262 paquets pour 6Go sur le macpro 2009 ,
avec pour la 1er fois un reboot lors de la maj ( pas grand chose dans la log sinon un changed /lib/firmware )

me laissant sans noyau , et en mise a jour partielle
==> clé USB , chroot , suppression du verrou , fin de la maj , forçage des noyaux , reboot et test
==> il fonctionne avec le noyau 6.1 ou 5.15
Répondre