Problèmes et questions concernant le noyau et le support matériel.
Répondre

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#1Messageil y a 2 semaines

Bonjour à tous,

J'utilise un bon vieux Ryzen 5 de première génération depuis maintenant 9 ans. C'est très certainement la seule pièce encore d'origine sur mon PC :gsourire:
Depuis plusieurs jours maintenant il chauffe... Au repos !
J'entends par là :
  • 50°C sans utilisation;
    60-65 avec Firefox;
    70-75 avec Steam (sans jeu lancé);
    80-105 lorsqu'un jeu est lancé (suivant le jeu)
J'ai très logiquement incriminé en premier mon système refroidissement. Je l'ai depuis maintenant 3-4 ans car mon ventirad précédent (Wraith Spire fourni avec le CPU par AMD) ne suffisait plus, l'été tout particuilèrement.
J'ai donc fait l'acquisition d'un Be quiet! Silent Loop 2 240mm, qui n'est pas réputé pour être le plus merdique.
Mais comme ce ne sont pas mes premiers déboires avec des kits de watercooling j'ai creusé la piste.

Voilà ce que j'ai fait :
- retiré intégralement le kit;
- changé la pate thermique;
- vidangé le liquide de refroidissement;
- rempli avec un liquide neuf + évacuation des bulles;
- soufflé le ventirad du watercooling.

J'ai tout replacé, même chose. J'ai regardé si le circuit se fait bien et oui, on sent la pression qui passe dans le circuit, et j'ai bien un tuyau bien chaud et un autre bien froid. Et le ventirad augmente bien sa vitesse lorsque le processeur chauffe.
J'ai pensé à un bug driver suite aux mises à jour Manjaro. J'ai laissé tourné sur le BIOS et le kit n'arrive pas à régulier en-dessous de 50°/55° ce que je trouve déjà élevé pour un usage au repos.

Côté utilisation justement, rien d'anormal dans les processus, avec un taux d'utilisation CPU à 3/6% au repos.
Pas d'autres problèmes dans les températures, juste le CPU qui pète un câble.

J'avoue être un peu bloqué. Avez-vous connu des expériences similaires ? Se peut-il que ce soit le processeur qui est en fin de vie ? C'est bien la première fois que j'ai un tel problème sur un kit watercooling apparemment fonctionnel.

Merci pour vos idées :wink:

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#2Messageil y a 2 semaines

tu peux fournir

inxi -Fza 
sudo mhwd-kernel -li
pacman -Qs ucode
cpupower frequency-info
il est possible que cela vienne de ucode et/ou de la version firmware bios.

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#3Messageil y a 2 semaines

Salut Stéphane,
Merci pour ta réponse rapide !

inxi -Fza                                                                                                                                                                                                                    ✔ 
System:
  Kernel: 6.5.13-7-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=6ca50b58-8833-4a65-bf08-5c791ba7abed rw quiet splash
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.113.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux
    base: Arch Linux
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 6210 date: 09/04/2023
CPU:
  Info: model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen level: v3
    note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
    stepping: 1 microcode: 0x8001138
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 2x8 MiB
  Speed (MHz): avg: 1419 high: 1550 min/max: 1550/3500 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1376 2: 1302
    3: 1550 4: 1376 5: 1377 6: 1376 7: 1550 8: 1550 9: 1273 10: 1375 11: 1550
    12: 1376 bogomips: 84027
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT]
    vendor: XFX Speedster MERC 319 driver: amdgpu v: kernel arch: RDNA-2
    code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3
    bus-ID: 0a:00.0 chip-ID: 1002:73bf class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon alternate: fbdev,vesa
    dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Dell SE2717H/HX
    serial: <filter> built: 2017 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi x11: drv: radeonsi
    inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.3-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 6800 XT (radeonsi
    navi21 LLVM 16.0.6 DRM 3.54 6.5.13-7-MANJARO) device-ID: 1002:73bf
    memory: 15.62 GiB unified: no
  API: Vulkan v: 1.3.274 layers: 6 device: 0 type: discrete-gpu
    name: AMD Radeon RX 6800 XT driver: amd v: 2023.Q4.3 (LLPC)
    device-ID: 1002:73bf surfaces: xcb,xlib
Audio:
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 0a:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0c:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Device-3: JMTek LLC. USB PnP Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-2:3 chip-ID: 0c76:161f class-ID: 0300
  API: ALSA v: k6.5.13-7-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 06:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
Drives:
  Local Storage: total: 3.75 TiB used: 3.16 TiB (84.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT4000MX500SSD1
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 046 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WDS120G1G0B-00RC30 size: 111.79 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 1000
    scheme: GPT
Partition:
  ID-1: / raw-size: 107.64 GiB size: 105.39 GiB (97.91%)
    used: 36.45 GiB (34.6%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 3.86 GiB used: 6.8 MiB (0.2%)
    priority: -2 dev: /dev/sdb2 maj-min: 8:18
Sensors:
  System Temperatures: cpu: 86.0 C mobo: 28.0 C gpu: amdgpu temp: 33.0 C
    mem: 32.0 C
  Fan Speeds (rpm): cpu: 997 case-1: 0 case-2: 948 case-3: 535 gpu: amdgpu
    fan: 0
  Power: 12v: 11.90 5v: N/A 3.3v: N/A vbat: N/A gpu: amdgpu watts: 8.00
Info:
  Memory: total: 32 GiB available: 31.25 GiB used: 3.42 GiB (10.9%)
  Processes: 356 Power: uptime: 3h 16m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform
    avail: shutdown,reboot,suspend,test_resume image: 12.49 GiB
    daemons: upowerd, org_kde_powerdevil, power-profiles-daemon Init: systemd
    v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1629 libs: 485 tools: pamac pm: flatpak pkgs: 0
    Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9 default: Bash
    v: 5.2.21 running-in: konsole inxi: 3.3.32

sudo mhwd-kernel -li                                                                                                                                                                                                        
Currently running: 6.5.13-7-MANJARO (linux65)
The following kernels are installed in your system:
   * linux61
   * linux65
   * linux61-rt
   * linux65-rt

pacman -Qs ucode                                                                                                                                                                                                     
local/amd-ucode 20231211.f2e52a1c-1
    Microcode update image for AMD CPUs

cpupower frequency-info                                                                                                                                                                                                     
analyse du CPU 11 :
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 11
  CPUs which need to have their frequency coordinated by software: 11
  maximum transition latency:  Cannot determine or is not supported.
  limitation matérielle : 1.55 GHz - 3.50 GHz
  available frequency steps:  3.50 GHz, 2.80 GHz, 1.55 GHz
  régulateurs disponibles : conservative ondemand userspace powersave performance schedutil
  tactique actuelle : la fréquence doit être comprise entre 1.55 GHz et 3.50 GHz.
                  Le régulateur "schedutil" est libre de choisir la vitesse
                  dans cette plage de fréquences.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.38 GHz (asserted by call to kernel)
  boost state support:
    Supported: no
    Active: no
Le CPU s'est mis à déconner sans que je ne flashe le bios.
Le bios a été flashé en novembre, mais pendant plusieurs mois le CPU ne chauffait pas.
Je me permets un EDIT du sujet topic:
Après revérification, quand je me mets dans le bios, la température CPU monte progressivement jusqu'à ce qu'il se mette en sécurité et s'éteigne (à 110° je crois).
Quand le PC tourne sur Linux, sauf grosse sollicitation du CPU, il arrive à tenir bon...

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#4Messageil y a 2 semaines

alors tu devrais tester avec les noyaux suivants
5.15 , 6.1 et 6.6,
je déconseille les noyaux rt sauf si tu as réellement un besoin spécifique sur ce sujet

tu ne va pas avoir trop de choix ,
il faut faire vérifier le cpu & le système de refroidissement.

as tu observé par hasard des sollicitations cpu type kworker ? ( voir avec htop )
depuis la maj de nov 2023 , il y a un flush systématique du cache1 sur division pour souci de sécurité.

c'est absolument pas bon signe si sous bios la température atteint le seuil limite
- soit le cpu ne fourni plus la bonne température ,
- soit la partie watercooling ne réagit pas suffisamment en terme de réaction / efficacité ( revoir la pâte thermique / contact attention si cuivre cela ne doit pas être oxydé )
- soit le watercooling n'a plus la bonne tempareture cpu

si probleme cpu change pour une version 5000x le prix est bien bas en ce moment ;-)

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#5Messageil y a 2 semaines

Salut Stéphane,

Alors je refais un EDIT rapide car suite à la rédaction de mon message précédent, mon PC s'est mis en sécurité à 108°C. Extinction immédiate.

Je te confirme au passage que j'ai pas moins de 98 processus en cours de kworker ! Est-ce lié ?
Image

Ok, je fais une màj noyau et je te redis.

Merci !

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#6Messageil y a 2 semaines

oui c'est lié :
il s'agit d’interruption généré par le hardware et le système ne trouve pas de process associé,
et cela donc fait monter très rapidement la température.

tu as un gros souci de refroidissement , le matériel doit être testé à part / cpu / refroidissement

et aussi test avec une "ancienne clé" USB live manjaro ( novembre )

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#7Messageil y a 2 semaines

Re,
J'ai mis à jour vers le kernel 6.6, il semble déjà que ça va beaucoup mieux.
Au démarrage du système, le CPU reste à 32°-35° au repos. Je l'ai laissé tourné 1h30 comme ça. Utilisation bureautique 40/45°, puis en jeu très gourmand, entre 80-90°. Retour sur le bureau, il est redescendu à 45/40° au repos.
Par contre j'ai maintenant 232 processus kworker. Comment se débarrasser de ce bug? Est-ce que ce sont des applications (les jeux par exemple) qui se ferment mal ?

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#8Messageil y a 2 semaines

essaye de désactiver indexation baloo , et regarde dans un 1er temps.
le souci est d'identifier ce qui est à l'origine de ces interruptions kworker.

pour ces cpu de l'époque le TDP représente mal énergie thermique a évacuer du cpu ,
j'avais un cpu 3600xt , il passait quasiment de 40 à 70 °C sur phase 100% cpu avec un Bequiet Dark pro.

avec le 5600x j'ai moins de problème

Surchauffe brutale du CPU (AMD Ryzen 5 1600 Gen1)

#9Messageil y a 2 semaines

Hello,

Bon alors pour ce qui est de la surchauffe, j'ai procédé à une solution très simple: j'ai interverti le processeur de ma conjointe et le mien. Remis en marche : même problème, surchauffe.
En touchant les tuyaux du watercooling, je me suis aperçu que je sentais la pression dans un des tuyaux, mais pas dans l'autre.... Bien sûr rien de démontable.
J'ai donc acheté un ventirad. Je l'ai reçu aujourd'hui, et miracle, CPU à 25°C au repos et pas plus de 60°C en jeu.

Je n'achèterai plus de kit watercooling, souvent source d'embrouilles. Et ce ventirad à 40 balles me fait baisser la température encore plus que le kit watercooling fonctionnel, et il est moins bruyant et moins gourmand.
Pour ce qui est de kworker j'ai désactivé l'indexation mais j'ai toujours autant de processus. Cela dit, le CPU est utilisé entre 1 et 2% au repos ce qui est parfaitement acceptable.

Merci ! :bien
Répondre