Problèmes et questions sur les applications multimédia.
Répondre

Bugs avec Kdenlive

#1Messageil y a 1 semaine

Gros bugs avec Kdenlive et Gnome depuis la mise à jour.

Le résultat étant en Anglais, pas certains de comprendre. J'ai tenté le forum Kdenlive/KDE et la réponse apporté n'a pas réglé le problème. En fait d'après ce que j'ai pu traduire c'est un problème Gnome donc....voir ailleurs.

Voici le message d'erreur

Le rendu de /home/pympc/Vidéos/Vietnam 2024 Sq1.mp4 a été interrompu par une erreur fatale

mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltsdl.so (libSDL-1.2.so.0: cannot open shared object file: No such file or directory)
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x5808710a52c0] st: 0 edit list: 1 Missing key frame while searching for timestamp: 3003 [mov,mp4,m4a,3gp,3g2,mj2 @ 0x5808710a52c0] st: 0 edit list 1 Cannot find an index entry before timestamp: 3003.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x580871fad7c0] st: 0 edit list: 1 Missing key frame while searching for timestamp: 3003 [mov,mp4,m4a,3gp,3g2,mj2 @ 0x580871fad7c0] st: 0 edit list 1 Cannot find an index entry before timestamp: 3003.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x580871fac740] st: 0 edit list: 1 Missing key frame while searching for timestamp: 3003 [mov,mp4,m4a,3gp,3g2,mj2 @ 0x580871fac740] st: 0 edit list 1 Cannot find an index entry before timestamp: 3003.
[mp3float @ 0x580871686700] Could not update timestamps for discarded samples.
[aac @ 0x72ddd92a0140] Could not update timestamps for skipped samples.
[swscaler @ 0x72dc1c000900] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dc08000900] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dc0c000900] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dc14000900] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x72dbf8000900] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dbe8000900] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dbf0000900] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x72dc00000900] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x72dc141dbb40] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dbf0182d80] deprecated pixel format used, make sure you did set range correctly
.........(là ce se répète...a quelque chiffres prêt)
[swscaler @ 0x72dbe81dbb40] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dc1c1dbb40] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dbf81dbb40] deprecated pixel format used, make sure you did set range correctly [swscaler @ 0x72dc08182d80] deprecated pixel format used, make sure you did set range correctly
[mp4 @ 0x72ddec200f80] Timestamps are unset in a packet for stream 1. This is deprecated and will stop working in the future. Fix your code to set the timestamps properly [mp4 @ 0x72ddec200f80] Encoder did not produce proper pts, making some up.

Une idée. D'avance merci

Bugs avec Kdenlive

#2Messageil y a 1 semaine

Bonjour

pour infos, l'Appimage, téléchargé et installé depuis le site officiel de Kdenlive fonctionne.

Sur le forum KDE/Kdenlive il m'a été suggérer de vérifier si Libmlt-è est bien installer. problème, ça ne semble pas exister via pacman !!!!

Bugs avec Kdenlive

#3Messageil y a 1 semaine

pymlinux a écrit : il y a 1 semaine si Libmlt-è est bien installer. problème, ça ne semble pas exister via pacman !!!!
:siffle c'est quoi ton "è" :mrgreen:

Il suffit de trouver le paquet depuis le fichier !
puisque ton app non installée chez moi, pacman -F libmltsdl.so, mais pour toi, si installé :

pacman -Qo /usr/lib/mlt-7/libmltsdl.so
ps: pour moi (donc toi si a jour en stable) c'est mlt 7.24.0-1

Note:
pour le sujet avec ton erreur avec tes erreurs (forum kde mais pas ici ?), donné à l'inter chez manjaro : ce n'était pas mlt le coupable ! mais d'autres paquets AUR pas à jour. :wink:
:cartonrouge: Nous sommes en rolling, il faut être à jour ! Et à noter qu'il n'y a pas de raison d'utiliser des paquets AUR, puisque ces 4 paquets sont dans nos dépôts (donc à jour)

Bugs avec Kdenlive

#4Messageil y a 1 semaine

Merci Papajoke de tes réponses...
papajoke a écrit : il y a 1 semaine
:siffle c'est quoi ton "è" :mrgreen:

c'est mon doigt qui joue les fainéants :gsourire:
papajoke a écrit : il y a 1 semaine Il suffit de trouver le paquet depuis le fichier !
puisque ton app non installée chez moi, pacman -F libmltsdl.so, mais pour toi, si installé :

pacman -Qo /usr/lib/mlt-7/libmltsdl.so
ps: pour moi (donc toi si a jour en stable) c'est mlt 7.24.0-1
hélas

pacman -Qo /usr/lib/mlt-7/libmltsdl.so                           ✔ 
erreur : aucun paquet ne contient /usr/lib/mlt-7/libmltsdl.so
Peut-être suis-je trop impatient :saispas:

Pour le forum Kdenlive/kde, j'ai tenté de poster pensant qu'il s'agissait d'un soucis avec Kdenlive et non Manjaro.
papajoke a écrit : il y a 1 semaine:cartonrouge: Nous sommes en rolling, il faut être à jour ! Et à noter qu'il n'y a pas de raison d'utiliser des paquets AUR, puisque ces 4 paquets sont dans nos dépôts (donc à jour)
problème c'est que je mets à jour dés que possible et parfois (par exemple avec Kdenlive) j'obtiens ce genre d'erreur.
C'est pour cela que je suis passé par l'Appimage non pas via Pacman mais directement sur le site. Et là tout fonctionne.

Bugs avec Kdenlive

#5Messageil y a 1 semaine

pymlinux a écrit : il y a 1 semaine hélas

pacman -Qo /usr/lib/mlt-7/libmltsdl.so                           ✔ 
erreur : aucun paquet ne contient /usr/lib/mlt-7/libmltsdl.so
Peut-être suis-je trop impatient :saispas:
Je ne comprends pas, ce n'est pas une dépendance de ton application ? c'est le cas avec kdenlive officiel, il est forcément installé (avec kdenlive-git aussi):

pacman -Si kdenlive
Dépend de                : ...  kxmlgui  mlt  purpose  ...
Ou alors, tu n'as plus que la version l'Appimage d'installée :saispas: Ce qui expliquerait que n'ais pas ce paquet, et dans ce cas, impossible de résoudre le problème s'il n'existe plus :lol:

Bugs avec Kdenlive

#6Messageil y a 1 semaine

Encore merci papajoke

Devant tou ça je me suis résolu à supprimer, via pacman, tout ce qui est Kdenlive. Puis j'ai dégagé tous les fichiers avec kdenlive qqchose

J'ai installé Kdenlive depuis les dépôts officiels. Pas brillant :saispas: : blocage écran, fermeture inopiné, donc désinstallatio comme précédemment.

J'ai installé l'Appimage via Pacman, message d'erreur....

J'ai installé Appimage depuis le site de Kdenlive et là tout fonctionne.....

Ahhhhhh Les joies de l'informatique :bien

Bon, il me reste plus qu'à re-re-re configurer Kdenlive et je vais pouvoir reprendre mon travail en cours.

merci
Répondre