Questions sur l'installation et la configuration de Manjaro Linux.
Répondre

Dépendance introuvable

#1Messageil y a 5 jours

:bjr:
J'ai une mise à jour qui m'est proposé mais impossible de la mener à sont terme car il manque la dépendance "nvidia-utils=550.90.07".

Le message:
"la satisfaction des dépendances a échoué:
- impossible de satisfaire la dépendance « nvidia-utils=550.90.07 » requise par lib32-nvidia-utils"

Comme je n'arrive pas à trouver cette dépendance j'ai fait la mise à jour en décochant lib32-nvidia-utils
mais je me sert de ma carte Nvidia .Est-ce une bonne idée ?
Dernière modification par andsonil y a 5 jours, modifié au total 1 fois.

Dépendance introuvable

#2Messageil y a 5 jours

Salut,
Désolé d'intervenir dans ta question sur le forum mais j'ai le même problème sur une autre dépendance. Lorsque j'essaie de faire la MAJ (importante car 533 MAJ disponibles), j'ai droit à ce message :
"La satisfaction des dépendances a échoué:
- l’installation de icu (75.1-1) casse la dépendance « libicui18n.so=74-64 » requise par electron25
- si possible, supprimer electron25 et réessayer"
Seul problème, c'est que je ne suis pas assez aguérri pour "supprimer electron25".
Je suis perdu, c'est la 1ère fois que ça m'arrive depuis 3 ans que je suis sous Manjaro.
Besoin d'aide.
Merci d'avance. Et désolé de ne pouvoir t'aider à solutionner ton problème.
Oliv

Dépendance introuvable

#3Messageil y a 5 jours

andson :
d'après le forum inter, il manquerait des paquets dans la mise à jour proposée (eh oui, ça arrive). Ils ont été ajoutés mais il faut attendre que les miroirs se synchronisent ...
https://forum.manjaro.org/t/stable-upda ... /163596/11

OlivGomb :
sujet aussi traité à l'inter, mais de la màj précédente
https://forum.manjaro.org/t/failed-inst ... 5/162889/5
pour voir les dépendances d'electron25 :
pacman -Qi electron25
ou
pactree -r electron25
pour le retirer :
sudo pacman -Rns electron25

Dépendance introuvable

#4Messageil y a 5 jours

:bjr:

Merci pour ta réponse. J'ai essayé la mise à jour en omettant la paquet concerné. Comme on vdit "A malin, malin et demi", au rédémarrage plus rien. Remise en état des fichierts (merci Timeshift)
redémarrage et là nouvelle mise à jour de 60 paquets dont la fameuse dépendance :gsourire: Mise à jour et redémarrage nickel.
Encore merci

Dépendance introuvable

#5Messageil y a 4 jours

@OlivGomb (ce n'était pas le même problème :wink: )

electron25 est un ancien paquet qui n'existe plus chez nous, nous nous pouvons avoir un (ancien) paquet aur qui lui désire encore aur/electron25.
Puisque nous somme à jour et que généralement les mainteneurs aur font bien le taf, il y a 99% de chance que ce paquet n'a aucune raison d'être chez nous.

pacman -Ssq electron
electron      # note, c'est la dernière donc la 30
electron23
electron27
electron28
electron29
electron30
Normalement, si le développeur de l'application (aur) fait bien son travail, nous ne devrions avoir besoin que de la version 30 voir 28.

Si electron25 n'est plus disponible dans nos dépots, c'est qu'aucune application de nos dépôts en a besoin.

ps: Si on ne fait pas de ménage dans nos orphelins, alors on peut trainer des dépendances inutiles (comme electron25) et , parfois (6 mois plus tard ou 6 ans) lors d'une mise à jour, pacman va nous le rappeler comme ce qui c'est passé pour toi.
Répondre