Problèmes et questions concernant l'édition KDE.
Répondre

Raccourci Clavier

#1Messageil y a 2 semaines

Bonjour,
La touche esc de mon clavier est partie. Je souhaite affecter à la touche ² la commande escape. Je suis sous KDE. J'ai jeté un oeil dans la rubrique Clavier - Raccourcis, je n'arrive pas à définir ce raccourci. j'ai essayé CTRL + 2, bof ce n'est pas concluant
Une idée sur la procédure détaillée de la manip, svp?

Borguy

Raccourci Clavier

#2Messageil y a 2 semaines

Peut-être avec xmodmap ? J'avais noté cela pour bricoler caps lock et mettre un ³ :
xmodmap Désactivation CapsLock et ajout ³
https://wiki.archlinux.org/index.php/xmodmap #Turn_CapsLock_into_Control

To create a key map (i.e. ~/.Xmodmap):                 $ xmodmap -pke > ~/.Xmodmap
To test the changes:                                                $ xmodmap ~/.Xmodmap

Dans le fichier ~/.Xmodmap :
• désactivation CapsLock :
!keycode  66 = Caps_Lock NoSymbol Caps_Lock   (! pour commenter)
keycode  66 =
(pas besoin d'autre chose, le fichier est chargé au lancement de la session)
• m² et m³ :
!keycode  49 = twosuperior asciitilde twosuperior asciitilde notsign notsign notsign  (! pour commenter)
keycode  49 = twosuperior threesuperior twosuperior threesuperior notsign notsign notsign

La touche 9 est Esc, tu copies le contenu dans la ligne de la touche 66 :
keycode 66 = Escape NoSymbol Escape
Tu sors de ta session et tu la rouvres et ça devait marcher.

Raccourci Clavier

#3Messageil y a 2 semaines

bonjour

@Borguy, tu cherches à redéfinir une touche et non un raccourci.

Avec wayland qui prend de plus en plus de place, sans doute prendre une autre technique ? Et certains utilitaires gèrent les 2 wiki arch

Raccourci Clavier

#4Messageil y a 2 semaines

Merci pour vos conseils.
J'ai choisi d'utiliser keyd et suivi les configurations proposées par ce site :
https://man.uex.se/1/keyd
Mon fichier de configuration defaulf.conf présent dans /etc/keyd est le suivant :

[ids]

*

1770:ff00

² = esc
1770:ff00 est le vendor ID de mon clavier MSI.
J'ai relancé avec un sudo keyd reload, rien y fait, la touche ² ne me donne pas la commande escape.
Je sèche !!!

Raccourci Clavier

#5Messageil y a 2 semaines

En listant les touches disponibles avec la commande :

keyd list-keys
la touche ² n'est pas présente dans la liste, scale oui.

J'ai donc remplacé la commande ² par scale. Rien y fait.
:tetu!

Raccourci Clavier

#6Messageil y a 2 semaines

Je tenterai :
[ids]
1770:ff00
[main]
esc = noop
scale = esc

mais je viens juste d'en lire la doc :gsourire:
et si scale ne convient pas, essaie d'abord avec une autre touche dont tu es sur du petit nom.
- keyd est-il lancé ?
- tu peux suivre les touches entrées avec keyd monitor
monitor [-t]

Print key events. If -t is supplied, also prints time since the last event in ms. Useful for discovering key names/device ids and debugging.

Raccourci Clavier

#7Messageil y a 2 semaines

La commande keyd monitor donne cela :

sudo keyd monitor
device added: 0001:0001 AT Translated Set 2 keyboard (/dev/input/event4)
device added: 046d:4057 Logitech B330/M330/M331 (/dev/input/event8)
device added: 0002:0007 SynPS/2 Synaptics TouchPad (/dev/input/event15)
device added: 0fac:0ade keyd virtual keyboard (/dev/input/event16)
device added: 0fac:1ade keyd virtual pointer (/dev/input/event17)
AT Translated Set 2 keyboard    0001:0001       enter up
Logitech B330/M330/M331 046d:4057       leftmouse down
Logitech B330/M330/M331 046d:4057       leftmouse up
AT Translated Set 2 keyboard    0001:0001       q down
AT Translated Set 2 keyboard    0001:0001       q up
AT Translated Set 2 keyboard    0001:0001       w down
AT Translated Set 2 keyboard    0001:0001       w up
AT Translated Set 2 keyboard    0001:0001       e down
AT Translated Set 2 keyboard    0001:0001       e up
AT Translated Set 2 keyboard    0001:0001       ` down
AT Translated Set 2 keyboard    0001:0001       ` up
AT Translated Set 2 keyboard    0001:0001       leftcontrol down
AT Translated Set 2 keyboard    0001:0001       c down
Apparemment il ne prend pas en compte mon type de clavier, il reste en qwerty. Le modèle est 0001:0001 et non 1770:ff00 La touche ² correspond à '.Je vais investiguer sur les codes claviers à indiquer.

Raccourci Clavier

#8Messageil y a 2 semaines

Je pense que le programme ne tient pas compte de langue du clavier.Je me suis résolu à prendre une autre touche. J'ai choisi la touche Pause.
Cela fonctionne.
Encore merci pour votre aide.

Borguy

Raccourci Clavier

#9Messageil y a 2 semaines

:salut:
Je viens de faire un petit test (sous plasma-x11, clavier fr) et c'est OK du premier coup :fete:

1) Trouver la touche :
sudo keyd monitor -t
ps: en effet j'ai "q" pour la touche a

+2504 ms    CHICONY HP USB Multimedia Keyboard      04f2:0841       ` down
+120 ms     CHICONY HP USB Multimedia Keyboard      04f2:0841       ` up
cool, chez moi, c'est ` pour le ² (comme toi)

2) test

dans default.conf, un petit copier/coller du caractère ` que me retourne "keyd monitor" :

[ids]
*

[main]
` = esc
sudo systemctl restart keyd et c'est OK (stop/start car je suppose qu'il ne lit le fichier qu'au chargement du service)

Si je remplace le * dans le fichier de config par 04f2:0841, même chose, c'est OK

Maintenant, il me reste à le lancer à chaque boot : sudo systemctl enable keyd

Raccourci Clavier

#10Messageil y a 2 semaines

Mais bien sûr, je n'avais pas pensé à cette astuce.
Super, modification effectuée et c'est parti.
Merci Papa :pompom: joke
Répondre